<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en">
<![endif]-->
<!--[if (!IE)]><!-->
<html lang="en">
<!--<![endif]-->

<head>
<meta charset="UTF-8" />
<title>The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS Metric | Kellblog</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://kellblog.com/xmlrpc.php" />
<meta name="google-site-verification" content="adw3f1WjeHaHKW0M-IbNzac50nCFkAcGTeWibDLnStU" />
		<script src='https://r-login.wordpress.com/remote-login.php?action=js&amp;host=kellblog.com&amp;id=11070789&amp;t=1486636159&amp;back=https%3A%2F%2Fkellblog.com%2F2013%2F12%2F01%2Fthe-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric%2F' type="text/javascript"></script>
		<script type="text/javascript">
		/* <![CDATA[ */
			if ( 'function' === typeof WPRemoteLogin ) {
				document.cookie = "wordpress_test_cookie=test; path=/";
				if ( document.cookie.match( /(;|^)\s*wordpress_test_cookie\=/ ) ) {
					WPRemoteLogin();
				}
			}
		/* ]]> */
		</script>
		<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//davidkellogg.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Kellblog &raquo; Feed" href="https://kellblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kellblog &raquo; Comments Feed" href="https://kellblog.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kellblog &raquo; The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS&nbsp;Metric Comments Feed" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s1.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1473172720h&ver=4.6.1-RC1-38499"}};
			!function(a,b,c){function d(a){var c,d,e,f,g,h=b.createElement("canvas"),i=h.getContext&&h.getContext("2d"),j=String.fromCharCode;if(!i||!i.fillText)return!1;switch(i.textBaseline="top",i.font="600 32px Arial",a){case"flag":return i.fillText(j(55356,56806,55356,56826),0,0),!(h.toDataURL().length<3e3)&&(i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,65039,8205,55356,57096),0,0),c=h.toDataURL(),i.clearRect(0,0,h.width,h.height),i.fillText(j(55356,57331,55356,57096),0,0),d=h.toDataURL(),c!==d);case"diversity":return i.fillText(j(55356,57221),0,0),e=i.getImageData(16,16,1,1).data,f=e[0]+","+e[1]+","+e[2]+","+e[3],i.fillText(j(55356,57221,55356,57343),0,0),e=i.getImageData(16,16,1,1).data,g=e[0]+","+e[1]+","+e[2]+","+e[3],f!==g;case"simple":return i.fillText(j(55357,56835),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode8":return i.fillText(j(55356,57135),0,0),0!==i.getImageData(16,16,1,1).data[0];case"unicode9":return i.fillText(j(55358,56631),0,0),0!==i.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity","unicode9"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNk91uwjAMhV9oXsaAiZtpz+ImXhrIn+IUtLefQzdWhoi4aX2i88V27apTBp1ipVhVmCD7ybrIyrsDsdpTzagPcFbPmvlJLeyDT/YCnFIxaFhZnwb0j3l1KuhdJDi+3gCLWgp5rGQgJ67/VA+T20nOQ8baHIGMQ/IUxNbDQn77pVo4Sv/dNKcsbhiGXIgZ5BncFKCOkuiWm49VnoZL84rrl6eHnC7q2Q3npDPjVEzVCcaXoFeupQQ+aawuxSsBnx5d6c+hTVFCq8S1kD0Idbt8wPIX9extqnMlikcsLdfPu0dx0g69tGLTtbj3WcfNvUVdTtYZS7Jxrdk5BlucAYxG/gg+b9FHeF9tdtvterdav+y/Aa48PWA=' type='text/css' media='all' />
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyFj+sKwjAMhV/IrHib+kN8ltrFkdqbTevQpzcD/aEOhUDIyZfDiRoSUDCudsjKSl0q5tuzNZZn6hcAnvqsCzaewgs2MRQMZWR9PJJDqIxZ96KJ0SlOcCly8cgs0MT2PRKFK+HwF7NYkjZnyMh0/3L1FZKrPQVWGZ080MGY4WOSq4Pfz1dtu14sd5utfQAruHB+'></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1377793621h' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s1.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://davidkellogg.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Accenture&#8217;s Key Considerations in SaaS Financial&nbsp;Applications' href='https://kellblog.com/2013/11/06/accentures-key-considerations-in-saas-financial-applications/' />
<link rel='next' title='The Pillorying of MarkLogic:  Why Selling Disruptive Technology To the Government is Hard and&nbsp;Risky' href='https://kellblog.com/2013/12/01/the-pillorying-of-marklogic-why-selling-disruptive-technology-to-the-government-is-hard-and-risky/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" />
<link rel='shortlink' href='http://wp.me/pKs17-2in' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=json&amp;url=https%3A%2F%2Fkellblog.com%2F2013%2F12%2F01%2Fthe-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/1.0/?format=xml&amp;url=https%3A%2F%2Fkellblog.com%2F2013%2F12%2F01%2Fthe-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS Metric" />
<meta property="og:url" content="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" />
<meta property="og:description" content="The software-as-a-service (SaaS) space is full of seemingly simple metrics that can quickly slip through your fingers when you try to grasp them.  For example, see Measuring SaaS Renewals Rates:  W…" />
<meta property="article:published_time" content="2013-12-01T18:19:56+00:00" />
<meta property="article:modified_time" content="2015-04-25T16:49:28+00:00" />
<meta property="og:site_name" content="Kellblog" />
<meta property="og:image" content="https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:site" content="@kellblog" />
<meta name="twitter:image" content="https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=240" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:creator" content="@kellblog" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />
<link rel="shortcut icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8ecfcffdb3cd0948a0c38207c0ca38d6?s=32" sizes="16x16" />
<link rel="icon" type="image/x-icon" href="https://secure.gravatar.com/blavatar/8ecfcffdb3cd0948a0c38207c0ca38d6?s=32" sizes="16x16" />
<link rel="apple-touch-icon-precomposed" href="https://secure.gravatar.com/blavatar/8ecfcffdb3cd0948a0c38207c0ca38d6?s=114" />
<link rel='openid.server' href='https://davidkellogg.wordpress.com/?openidserver=1' />
<link rel='openid.delegate' href='https://davidkellogg.wordpress.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://kellblog.com/osd.xml" title="Kellblog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="Kellblog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="The official blog of Dave Kellogg" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://kellblog.com/feed/;icon-uri=https://secure.gravatar.com/blavatar/8ecfcffdb3cd0948a0c38207c0ca38d6?s=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s2.wp.com/i/favicon.ico" /><meta name="title" content="The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS&nbsp;Metric | Kellblog on WordPress.com" />
<meta name="description" content="The software-as-a-service (SaaS) space is full of seemingly simple metrics that can quickly slip through your fingers when you try to grasp them.  For example, see Measuring SaaS Renewals Rates:  Way More Than Meets the Eye for a two-thousand-word post examining the many possible answers to the seemingly simple question, “what’s your renewal rate?” In this post,&hellip;" />
		<script type="text/javascript" src="//c.amazon-adsystem.com/aax2/amzn_ads.js"></script>
		<script type="text/javascript">
		try { amznads.getAds("3033"); } catch(e) { /* ignore */ }
		</script>
		<script type="text/javascript">
		try {
			var a9_p = amznads.getKeys(),
			_ipw_custom = {
				wordAds: '0',
				adSafe: '1',
				domain: 'kellblog.com',
				pageURL: 'https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/'
			};
			if("undefined"!=typeof a9_p&&""!=a9_p&&null!==a9_p&&"[object Array]"===Object.prototype.toString.call(a9_p)){var a="",b=0,c=a9_p.length;a9_p.sort();for(var d=0;d<c;d++){a9_p[d-b]=a9_p[d-b].replace(/a1x6p/,"a160x600p");var e=a9_p[d-b].split("p");e[0]==a&&(a9_p.splice(d-b,1),b++);a=e[0]}_ipw_custom.amznPay=a9_p};document.close();
		} catch(e) {}
		</script> 		<script type="text/javascript" src="https://static.criteo.net/js/ld/publishertag.js"></script>
 		<script type="text/javascript" src="//s.pubmine.com/head.js"></script>
		<script type="text/javascript">
		jQuery(window).ready(function () {
			jQuery("a.wpa-about").text("Advertisements");
		});
		</script><link rel="amphtml" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/amp/" /><style type="text/css" id="syntaxhighlighteranchor"></style>
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s0.wp.com/?custom-css=1&#038;csblog=Ks17&#038;cscache=6&#038;csrev=49" />
		<script type="text/javascript">
	window.google_analytics_uacct = "UA-52447-2";
</script>

<script type="text/javascript">
	var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-52447-2']);
	_gaq.push(['_setDomainName', 'none']);
	_gaq.push(['_setAllowLinker', true]);
	_gaq.push(['_initData']);
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		(document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(ga);
	})();
</script>
</head>

<body class="single single-post postid-8827 single-format-standard mp6 customizer-styles-applied two-column content-sidebar highlander-enabled highlander-light">
<div id="container" class="hfeed contain">
	<div id="header">
		<div id="masthead" role="banner">
						<div id="site-title">
				<span>
					<a href="https://kellblog.com/" title="Kellblog" rel="home">Kellblog</a>
				</span>
			</div>
			<div id="site-description">The official blog of Dave Kellogg</div>
		</div><!-- #masthead -->

		<div id="access" role="navigation">
		  			<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
						<div class="menu"><ul><li ><a href="https://kellblog.com/">Home</a></li><li class="page_item page-item-6950"><a href="https://kellblog.com/best-of-kellblog/">Best of Kellblog</a></li><li class="page_item page-item-6948"><a href="https://kellblog.com/frequently-asked-questions/">Frequently Asked Questions</a></li></ul></div>
		</div><!-- #access -->

		<div id="branding">
					</div><!-- #branding -->
	</div><!-- #header -->

	<div id="content-box">

<div id="content-container">
	<div id="content" role="main">

	
		<div id="nav-above" class="navigation">
			<div class="nav-previous"><a href="https://kellblog.com/2013/11/06/accentures-key-considerations-in-saas-financial-applications/" rel="prev"><span class="meta-nav">&larr;</span> Accenture&#8217;s Key Considerations in SaaS Financial&nbsp;Applications</a></div>
			<div class="nav-next"><a href="https://kellblog.com/2013/12/01/the-pillorying-of-marklogic-why-selling-disruptive-technology-to-the-government-is-hard-and-risky/" rel="next">The Pillorying of MarkLogic:  Why Selling Disruptive Technology To the Government is Hard and&nbsp;Risky <span class="meta-nav">&rarr;</span></a></div>
		</div><!-- #nav-above -->

		<div id="post-8827" class="post-8827 post type-post status-publish format-standard hentry category-enterprise-software category-finance category-metrics category-saas category-startups category-venture-capital">

			
			<h1 class="entry-title">The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS&nbsp;Metric</h1>
							<div class="entry-meta">
					<span class="meta-prep meta-prep-author">Posted on</span> <a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" title="10:19 am" rel="bookmark"><span class="entry-date">December 1, 2013</span></a> <span class="comments-link"><span class="meta-sep">|</span> <a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comments">47 Comments</a></span>
									</div><!-- .entry-meta -->
			
			<div class="entry-content">
				<p>The software-as-a-service (<a href="http://en.wikipedia.org/wiki/Software_as_a_service">SaaS</a>) space is full of seemingly simple metrics that can quickly slip through your fingers when you try to grasp them.  For example, see <a href="https://kellblog.com/2013/10/04/measuring-saas-or-cloud-renewal-rates-way-more-than-meets-the-eye/">Measuring SaaS Renewals Rates:  Way More Than Meets the Eye</a> for a two-thousand-word post examining the many possible answers to the seemingly simple question, “what’s your renewal rate?”</p>
<p>In this post, I’ll do a similar examination to the slightly simpler question, “what’s your customer acquisition cost (CAC) ratio?”</p>
<p>I write these posts, by the way, not because I revel in the detail of calculating SaaS / cloud metrics, but rather because I cannot stand when groups of otherwise very intelligent people have long discussions based on ill-defined metrics.  The first rule of metrics is to understand what they are and what they mean before entertaining long discussions and/or making important decisions about them.  Otherwise you’re just <a href="http://en.wikipedia.org/wiki/How_many_angels_can_dance_on_the_head_of_a_pin%3F">counting angels on pinheads</a>.</p>
<p>The intent of the CAC ratio is to determine the cost associated with acquiring a customer in a subscription business.  When trying to calculate it, however, there are six key issues to consider:</p>
<ul>
<li>Months vs. years</li>
<li>Customers vs. dollars</li>
<li>Revenue on top vs. bottom</li>
<li>Revenue vs. gross margin</li>
<li>The cost of customer success</li>
<li>Time periods of S&amp;M</li>
</ul>
<p><b>Months vs. Years</b></p>
<p>The first question &#8212; which relates not only to CAC but also to many other SaaS metrics:  is your business inherently monthly or annual?</p>
<p>Since the SaaS movement started out with monthly pricing and monthly payments, many SaaS businesses conceptualized themselves as monthly and thus many of the early SaaS metrics were defined in monthly terms (e.g., monthly recurring revenue, or MRR).</p>
<p>While for some businesses this undoubtedly remains true, for many others – particularly in the enterprise space – the real rhythm of the business is annual.  Salesforce.com, the enterprise SaaS pioneer, figured this out early on as customers actually encouraged the company to move to an annual rhythm, for among other reasons, to avoid the hassle associated with monthly billing.</p>
<p>Hence, many SaaS companies today view themselves as in the business of selling annual subscriptions and talk not about MRR, but ARR (annual recurring revenue).</p>
<p><b>Customers vs. Dollars</b></p>
<p>If you ask some cloud companies their CAC ratio, they will respond with a dollar figure – e.g., “it costs us $12,500 to acquire a customer.”  Technically speaking, I’d call this customer acquisition cost, and not a cost ratio.</p>
<p>There is nothing wrong with using customer acquisition cost as a metric and, in fact, the more your business is generally consistent and the more your customers resemble each other, the more logical it is to say things like, “our average customer costs $2,400 to acquire and pays us $400/month, so we recoup our customer acquisition cost in six months.”</p>
<p>However, I believe that in most SaaS businesses:</p>
<ul>
<li>The company is trying to run a “velocity” and an “enterprise” model in parallel.</li>
</ul>
<ul>
<li>The company may also be trying to run a freemium model (e.g., with a free and/or a low-price individual subscription) as well.</li>
</ul>
<p>Ergo, your typical SaaS company might be running three business models in parallel, so wherever possible, I’d argue that you want to segment your CAC (and other metric) analysis.</p>
<p>In so doing, I offer a few generic cautions:</p>
<ul>
<li>Remember to avoid the easy mistake of taking “averages of averages,” which is incorrect because it does not reflect weighting the size of the various businesses.</li>
</ul>
<ul>
<li>Remember that in a bi-modal business that the average of the two real businesses represents a fictional mathematical middle.</li>
</ul>
<p><a href="https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png"><img data-attachment-id="8831" data-permalink="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/avg-of-avg-2/" data-orig-file="https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=500&#038;h=192" data-orig-size="729,281" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="avg of avg" data-image-description="" data-medium-file="https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=500&#038;h=192?w=300" data-large-file="https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=500&#038;h=192?w=500" class="aligncenter size-full wp-image-8831" src="https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=500&#038;h=192" alt="avg of avg" width="500" height="192" srcset="https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=498&amp;h=192 498w, https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=150&amp;h=58 150w, https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png?w=300&amp;h=116 300w, https://davidkellogg.files.wordpress.com/2013/12/avg-of-avg1.png 729w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p>For example, the “weighted avg” column above is mathematically correct, but it contains relatively little information.  In the same sense that you’ll never find a family with 1.8 children, you won&#8217;t find a customer with $12.7K in revenue/month.  The reality is not that the company’s average months to recoup CAC is a seemingly healthy 10.8 – the reality is the company has one very nice business (SMB) where it takes only 6 months to recoup CAC and one very expensive one where it takes 30.  How you address the 30-month CAC recovery is quite different from how you might try to squeeze a month or two out the 10.8.</p>
<p>Because customers come in so many different sizes, I dislike presenting CAC as an average cost to acquire a customer and prefer to define CAC as an average cost to acquire a dollar of annual recurring revenue.</p>
<p><b>Revenue on Top vs. Bottom</b></p>
<p>When I first encountered the CAC ratio is was in a <a href="http://www.bvp.com/cloud">Bessemer</a> white paper, and it looked like this.</p>
<p><a href="https://davidkellogg.files.wordpress.com/2013/12/cac-picture.png"><img src="https://davidkellogg.files.wordpress.com/2013/12/cac-picture.png?w=350&#038;h=68" alt="cac picture" width="350" height="68" /></a></p>
<p>In English, Bessemer defined the 3Q08 CAC as the annualized amount of incremental gross margin in 3Q08 divided by total S&amp;M expense in 2Q08 (the prior quarter).</p>
<p>Let’s put aside (for a while) the choice to use gross margin as opposed to revenue (e.g., ARR) in the numerator.  Instead let’s focus on whether revenue makes more sense in the numerator or the denominator.  Should we think of the CAC ratio as:</p>
<ul>
<li>The amount of S&amp;M we spend to generate $1 of revenue</li>
<li>The amount of revenue we get per $1 of S&amp;M cost</li>
</ul>
<p>To me, Bessemer defined the ratio upside down.  The customer acquisition cost ratio should be the amount of S&amp;M spent to acquire a dollar of (annual recurring) revenue.</p>
<p><a href="http://www.scalevp.com/">Scale Venture Partners</a> evidently agreed  and published a metric they called the <a href="http://0344593.netsolvps.com/magic-number-math">Magic Number</a>:</p>
<blockquote><p>Take the change in subscription revenue between two quarters, annualize it (multiply by four), and divide the result by the sales and marketing spend for the earlier of the two quarters.</p></blockquote>
<p>This changes the Bessemer CAC to use subscription revenue, not gross margin, as well as inverts it.  I think this is very close to CAC should be calculated.  See below for more.</p>
<p>Bessemer later (kind of) conceded the inversion &#8212; while they side-stepped redefining the CAC, <em>per se</em>, they now emphasize a new metric called “CAC payback period” which puts S&amp;M in the numerator.</p>
<p><b>Revenue vs. Gross Margin</b></p>
<p>While Bessemer has written some great papers on Cloud Computing (including their <a href="https://bvp.app.box.com/10lawsofcloudcomputing">Top Ten Laws of Cloud Computing</a> and <a href="https://bvp.app.box.com/30-QA-for-SaaS-Revenue-Leaders">Thirty Q&amp;A that Every SaaS Revenue Leader Needs to Know</a>) I think they have a tendency to over-think things and try to extract too much from a single metric in defining their CAC.  For example, I think their choice to use gross margin, as opposed to ARR, is a mistake.</p>
<p>One metric should be focused on measuring one specific item. To measure the overall business, you should create a great <b>set</b> of metrics that work together to show the overall state of affairs.</p>
<p><a href="https://davidkellogg.files.wordpress.com/2013/12/leaky.png"><img data-attachment-id="8833" data-permalink="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/leaky/" data-orig-file="https://davidkellogg.files.wordpress.com/2013/12/leaky.png?w=88&#038;h=88" data-orig-size="347,346" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="leaky" data-image-description="" data-medium-file="https://davidkellogg.files.wordpress.com/2013/12/leaky.png?w=88&#038;h=88?w=300" data-large-file="https://davidkellogg.files.wordpress.com/2013/12/leaky.png?w=88&#038;h=88?w=347" class=" wp-image-8833 alignleft" src="https://davidkellogg.files.wordpress.com/2013/12/leaky.png?w=88&#038;h=88" alt="leaky" width="88" height="88" srcset="https://davidkellogg.files.wordpress.com/2013/12/leaky.png?w=88&amp;h=88 88w, https://davidkellogg.files.wordpress.com/2013/12/leaky.png?w=176&amp;h=176 176w, https://davidkellogg.files.wordpress.com/2013/12/leaky.png?w=150&amp;h=150 150w" sizes="(max-width: 88px) 100vw, 88px" /></a></p>
<p>I think of a SaaS company as a leaky bucket.  The existing water level is a company’s starting ARR.  During a time period the company adds water to the bucket in form of sales (new ARR), and water leaks out of the bucket in the form of churn.</p>
<ul>
<li>If you want to know how efficient a company is at adding water to the bucket, look at the CAC ratio.</li>
<li>If you want to know what happens to water once in the bucket, look at the <a href="https://kellblog.com/2013/10/04/measuring-saas-or-cloud-renewal-rates-way-more-than-meets-the-eye/">renewal rates</a>.</li>
<li>If you want to know how efficiently a company runs its SaaS service, look at the subscription gross margins.</li>
</ul>
<p>There is no need to blend the efficiency of operating the SaaS service with the efficiency of customer acquisition into a single metric.  First, they are driven by different levers.  Second, to do so invariably means that being good at one of them can mask being bad at the other.  You are far better off, in my opinion, looking at these three important efficiencies independently.</p>
<p><b>The Cost of Customer Success</b></p>
<p>Most SaaS companies have “customer success” departments that are distinct from their customer support departments (which are accounted for in <a href="http://www.investopedia.com/terms/c/cogs.asp">COGS</a>).  The mission of the customer success team is to maximize the renewals rate – i.e., to prevent water from leaking out of the bucket – and towards this end they typically offer a form of proactive support and adoption monitoring to ferret out problems early, fix them, and keep customers happy so they will renew their subscriptions.</p>
<p>In addition, the customer success team often handles basic upsell and cross-sell, selling customers additional seats or complementary products.  Typically, when a sale to an existing customer crosses some size or difficultly threshold, it will be kicked back to sales.  For this reason, I think of customer success as handling incidental upsell and cross-sell.</p>
<p>The question with respect to the CAC is what to do with the customer success team.  They are “sales” to the extent that they are renewing, upselling, and cross-selling customers.  However, they are primarily about ARR preservation as opposed to new ARR.</p>
<p>My preferred solution is to exclude both the results from and the cost of the customer success team in calculating the CAC.  That is, my definition of the CAC is:</p>
<p style="text-align:center;"><a href="https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png"><img data-attachment-id="8868" data-permalink="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/dk-cac-pic-4/" data-orig-file="https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png?w=450&#038;h=73" data-orig-size="654,107" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="dk cac pic" data-image-description="" data-medium-file="https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png?w=450&#038;h=73?w=300" data-large-file="https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png?w=450&#038;h=73?w=500" class="aligncenter  wp-image-8868" src="https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png?w=450&#038;h=73" alt="dk cac pic" width="450" height="73" srcset="https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png?w=446&amp;h=73 446w, https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png?w=150&amp;h=25 150w, https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png?w=300&amp;h=49 300w, https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic3.png 654w" sizes="(max-width: 450px) 100vw, 450px" /></a></p>
<p>I explicitly exclude the cost customer success in the numerator and exclude the effects of churn in the denominator by looking only at the new ARR added during the quarter.  This formula works on the assumption that the customer success team is selling a relatively immaterial amount of new ARR (and that their primary mission instead is ARR preservation).  If that is not true, then you will need to exclude both the new ARR from customer success as well as its cost.</p>
<p>I like this formula because it keeps you focused on what the ratio is called:  customer acquisition cost.  We use revenue instead of gross margin and we exclude the cost of customer success because we are trying to build a ratio to examine one thing:  how efficiently do I add new ARR to the bucket?  My CAC deliberately says nothing about:</p>
<ul>
<li>What happens to the water once S&amp;M pours it in the bucket.  A company might be tremendous at acquiring customers, but terrible at keeping them (e.g., offer a poor quality service).  If you look at net change in ARR across two periods then you are including both the effects of new sales and churn.  That is why I look only at new ARR.</li>
</ul>
<ul>
<li>The profitability of operating the service.  A company might be great at acquiring customers but unable to operate its service at a profit.  You can see that easily in subscription gross margins and don’t need to embed that in the CAC.</li>
</ul>
<p>There is a problem, of course.  For public companies you will not be able to calculate my CAC because in all likelihood customer success has been included in S&amp;M expense but not broken out and because you can typically only determine the net change in subscription revenues and not the amounts of new ARR and churn.  Hence, for public companies, the <a href="http://www.scalevp.com/magic-number-math">Magic Number</a> is probably your best metric, but I’d just call it 1/CAC.</p>
<p>My definition is pretty close to that used by <a href="http://www.pacific-crest.com/">Pacific Crest</a> in their <a href="http://www.forentrepreneurs.com/2013-saas-survey/">annual survey</a>, which uses yet another slightly different definition of the CAC:  how much do you spend in S&amp;M for a dollar of annual contract value (ACV) from a new customer?</p>
<p>(Note that many vendors include first-year professional services in their definition of ACV which is why I prefer ARR.  Pacific Crest, however, defines ACV so it is equivalent to ARR.)</p>
<p>I think Pacific Crest’s definition has very much the same spirit as my own.  I am, by comparison, deliberately simpler (and sloppier) in assuming that customer success not providing a lot of new ARR (which is not to say that a company is not making significant sales to its customer base – but is to say that those opportunities are handed back to the sales function.)</p>
<p>Let’s see the distribution of CAC ratios reported in Pacific Crest’s recent, wonderful survey:</p>
<p><a href="https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png"><img data-attachment-id="8835" data-permalink="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/pac-crest-cac/" data-orig-file="https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png?w=500&#038;h=371" data-orig-size="578,429" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;}" data-image-title="pac crest cac" data-image-description="" data-medium-file="https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png?w=500&#038;h=371?w=300" data-large-file="https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png?w=500&#038;h=371?w=500" class="aligncenter size-full wp-image-8835" src="https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png?w=500&#038;h=371" alt="pac crest cac" width="500" height="371" srcset="https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png?w=500&amp;h=371 500w, https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png?w=150&amp;h=111 150w, https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png?w=300&amp;h=223 300w, https://davidkellogg.files.wordpress.com/2013/12/pac-crest-cac.png 578w" sizes="(max-width: 500px) 100vw, 500px" /></a></p>
<p>Wow.  It seems like a whole lot of math and analysis to come back and say:  “<strong>the answer is 1.</strong>”</p>
<p>But that’s what it is.  A healthy CAC ratio is around 1, which means that a company’s S&amp;M investment in acquiring a new customer is repaid in about a year.  Given COGS associated with running the service and a company’s operating expenses, this implies that the company is not making money until at least year 3.  This is why higher CACs are undesirable and why SaaS businesses care so much about renewals.</p>
<p>Technically speaking, there is no absolute “right” answer to the CAC question in my mind.  Ultimately the amount you spend on anything should be related to what it’s worth, which means we need <a href="http://www.forentrepreneurs.com/saas-metrics-2-definitions/">relate customer acquisition cost to customer lifetime value (LTV)</a>.</p>
<p>For example, a company whose typical customer lifetime is 3 years needs to have a CAC well less than 1, whereas a company with a 10 year typical customer lifetime can probably afford a CAC of more than 2.  (The NPV of a 10-year subscription increasing price at 3% with a 90% renewal rate and discount at 8% is nearly $7.)</p>
<p><b>Time Periods of S&amp;M Expense</b></p>
<p>Let me end by taking a practical position on what could be a huge rat-hole if examined from first principles.  The one part of the CAC we&#8217;ve not yet challenged is the use of the prior <b>quarter’s</b> sales and marketing expense.  That basically assumes a 90-day sales cycle – i.e., that total S&amp;M expense from the prior quarter is what creates ARR in the current quarter.  In most enterprise SaaS companies this isn’t true.  Customers may engage with a vendor over a period of a year before signing up.  Rather than creating some overlapped ramp to try and better model how S&amp;M expense turns into ARR, I generally recommend simply using the prior quarter for two reasons:</p>
<ul>
<li>Some blind faith in offsetting errors theory.  (e.g., if 10% of this quarter’s S&amp;M won’t benefit us for a year than 10% of a year ago’s spend did the same thing, so unless we are growing very quickly this will sort of cancel out).</li>
</ul>
<ul>
<li>Comparability.  Regardless of its fundamental correctness, you will have nothing to compare to if you create your own “more accurate” ramp.</li>
</ul>
<p>I hope you&#8217;ve enjoyed this journey of CAC discovery.  Please let me know if you have questions or comments.</p>
		<div class="wpcnt">
			<div class="wpa wpmrec">
				<a class="wpa-about" href="https://en.support.wordpress.com/about-these-ads/" rel="nofollow"></a>
				        <div id="crt-1382826349" style="width:300px;height:250px;"></div>
        <script type="text/javascript">
        var o = document.getElementById('crt-1382826349');
        if ("undefined"!=typeof Criteo) {
            var p = o.parentNode;
            p.style.setProperty('display', 'inline-block', 'important');
            o.style.setProperty('display', 'block', 'important');
            Criteo.DisplayAcceptableAdIfAdblocked({zoneid:388248,containerid:"crt-1382826349",collapseContainerIfNotAdblocked:true,"callifnotadblocked": function () {var o = document.getElementById('crt-1382826349'); o.style.setProperty('display','none','important');o.style.setProperty('visbility','hidden','important'); }
        });
        } else {
            o.style.setProperty('display', 'none', 'important');
            o.style.setProperty('visibility', 'hidden', 'important');
        }
        </script>
				<div class="u">
					<script type='text/javascript'>
					(function(g){if("undefined"!=typeof g.__ATA){g.__ATA.initAd({sectionId:26942, width:300, height:250});}})(window);
					</script>
				</div>
			</div>
		</div><div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow" data-shared="sharing-twitter-8827" class="share-twitter sd-button share-icon no-text" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow" data-shared="sharing-linkedin-8827" class="share-linkedin sd-button share-icon no-text" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-8827" class="share-facebook sd-button share-icon no-text" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?share=facebook" target="_blank" title="Share on Facebook"><span></span><span class="sharing-screen-reader-text">Share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow" data-shared="sharing-pinterest-8827" class="share-pinterest sd-button share-icon no-text" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon no-text" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?share=email" target="_blank" title="Click to email"><span></span><span class="sharing-screen-reader-text">Click to email (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon no-text" href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-11070789-8827-589c447f276d8' data-src='//widgets.wp.com/likes/#blog_id=11070789&amp;post_id=8827&amp;origin=davidkellogg.wordpress.com&amp;obj_id=11070789-8827-589c447f276d8' data-name='like-post-frame-11070789-8827-589c447f276d8'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>							</div><!-- .entry-content -->

			<div class="entry-info">
							This entry was posted in <a href="https://kellblog.com/category/enterprise-software/" rel="category tag">Enterprise Software</a>, <a href="https://kellblog.com/category/finance/" rel="category tag">Finance</a>, <a href="https://kellblog.com/category/metrics/" rel="category tag">Metrics</a>, <a href="https://kellblog.com/category/saas/" rel="category tag">SaaS</a>, <a href="https://kellblog.com/category/startups/" rel="category tag">Startups</a>, <a href="https://kellblog.com/category/venture-capital/" rel="category tag">Venture Capital</a>. Bookmark the <a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" title="Permalink to The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS&nbsp;Metric" rel="bookmark">permalink</a>.							</div><!-- .entry-info -->
		</div><!-- #post-## -->

		<div id="nav-below" class="navigation">
			<div class="nav-previous"><a href="https://kellblog.com/2013/11/06/accentures-key-considerations-in-saas-financial-applications/" rel="prev"><span class="meta-nav">&larr;</span> Accenture&#8217;s Key Considerations in SaaS Financial&nbsp;Applications</a></div>
			<div class="nav-next"><a href="https://kellblog.com/2013/12/01/the-pillorying-of-marklogic-why-selling-disruptive-technology-to-the-government-is-hard-and-risky/" rel="next">The Pillorying of MarkLogic:  Why Selling Disruptive Technology To the Government is Hard and&nbsp;Risky <span class="meta-nav">&rarr;</span></a></div>
		</div><!-- #nav-below -->

		
<div id="comments">

	
			<h3 id="comments-title">
			47 responses to &ldquo;<span>The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS&nbsp;Metric</span>&rdquo;		</h3>

		
		<ol class="commentlist">
				<li class="comment even thread-even depth-1 highlander-comment" id="li-comment-9612">
		<div id="comment-9612">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://plus.google.com/109644253777236142149' rel='external nofollow' class='url'>James Ferguson</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-9612">
				December 2, 2013 at 9:41 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=9612#respond' onclick='return addComment.moveForm( "comment-9612", "9612", "respond", "8827" )' aria-label='Reply to James Ferguson'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Thanks for the useful summary Dave</p>
<p>I wonder if you could advise your opinion on the following:</p>
<p>We resell via B2B2B  (essentially via utilities and related building service companies). Our SaaS sits on the utility platform and is a single-click subscription purchase (client id / billing etc is already handled)</p>
<p>So we see after long years of speculative &#8220;whale hunting&#8221; we see a very large market for each harpoon that sticks (no disrespect to clients or whales intended) </p>
<p>For each reseller, the accessible market is growing very fast (we are Automatic Meter Reading dependent which are a rolling out technology). </p>
<p>As we support new products/services there is scope for cross-sales and upsales</p>
<p>So the question &#8211; who are our &#8220;customers&#8221; for any CAC metric the reseller or the user</p>
<p>The reseller is a step function (no meaningful metrics no two utilities are identical (the idea of cohorts of utilities seems just silly), but once servicing the reseller end user CAC is effectively zero (we cannot market at them directly) and we expect extremely high retention and organic sales.</p>
<p>So in talking to VC we have no meaningful way to present figures. </p>
<p>What would you suggest ?</p>
<p>Thanks James</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment odd alt thread-odd thread-alt depth-1 highlander-comment" id="li-comment-9613">
		<div id="comment-9613">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://twitter.com/sammefford' rel='external nofollow' class='url'>Sam Mefford</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-9613">
				December 2, 2013 at 10:48 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=9613#respond' onclick='return addComment.moveForm( "comment-9613", "9613", "respond", "8827" )' aria-label='Reply to Sam Mefford'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Am I reading the &#8220;Magic Number&#8221; wrong?<br />
&gt; Take the change in subscription revenue between two quarters,<br />
&gt; annualize it (multiply by four), and divide the result by the sales and<br />
&gt; marketing spend for the earlier of the two quarters.</p>
<p>It sounds exactly the same as your Bessemer example.  Dave, you&#8217;re proposing we use the New ARR as the denominator, not the sales and marketing, right?</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-davidkellogg bypostauthor even thread-even depth-1 highlander-comment" id="li-comment-9616">
		<div id="comment-9616">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://davidkellogg.wordpress.com' rel='external nofollow' class='url'>Dave Kellogg</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-9616">
				December 2, 2013 at 12:24 pm</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=9616#respond' onclick='return addComment.moveForm( "comment-9616", "9616", "respond", "8827" )' aria-label='Reply to Dave Kellogg'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Sam,</p>
<p>Two different issues: [1] should ARR/revenue be on top or the bottom &#8212; I think on top because I think &#8220;how much do we spend to acquire a $1 of subscription revenue.  [2] the difference b/w &#8220;change in ARR&#8221; (which is new ARR &#8211; churn ARR vs. simply using new ARR.  i.e., churn should be excluded imho because you can see it in other ratios and the intent of the CAC is to determine your efficiency at *acquiring* customers.</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-davidkellogg bypostauthor odd alt thread-odd thread-alt depth-1 highlander-comment" id="li-comment-9617">
		<div id="comment-9617">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://davidkellogg.wordpress.com' rel='external nofollow' class='url'>Dave Kellogg</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-9617">
				December 2, 2013 at 12:34 pm</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=9617#respond' onclick='return addComment.moveForm( "comment-9617", "9617", "respond", "8827" )' aria-label='Reply to Dave Kellogg'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>James,</p>
<p>I&#8217;m not sure I see the problem.  Channel or no channel, should you not be able to calculate total S&amp;M expense and new ARR per quarter.  If you can, you can calculate a CAC ratio.  Per-customer CAC might be harder, but a CAC ratio should be good enough..</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment even thread-even depth-1 highlander-comment" id="li-comment-9618">
		<div id="comment-9618">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://twitter.com/sammefford' rel='external nofollow' class='url'>Sam Mefford</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-9618">
				December 2, 2013 at 1:21 pm</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=9618#respond' onclick='return addComment.moveForm( "comment-9618", "9618", "respond", "8827" )' aria-label='Reply to Sam Mefford'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Dave,</p>
<p>Agreed on point #2.  I&#8217;m just not understanding point #1, because the graphic which you label &#8220;my definition of the CAC is:&#8221; shows ARR on the bottom: <a href="https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic.png" rel="nofollow">https://davidkellogg.files.wordpress.com/2013/12/dk-cac-pic.png</a></p>
</div>

	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-davidkellogg bypostauthor odd alt depth-2 highlander-comment" id="li-comment-9621">
		<div id="comment-9621">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://davidkellogg.wordpress.com' rel='external nofollow' class='url'>Dave Kellogg</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-9621">
				December 2, 2013 at 2:53 pm</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=9621#respond' onclick='return addComment.moveForm( "comment-9621", "9621", "respond", "8827" )' aria-label='Reply to Dave Kellogg'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Sam,</p>
<p>Apologies because I got myself inverted on the magic number.  Because I&#8217;d always been told by certain former colleagues that the magic number is the inverse of the Besemmer CAC (and because Scale didn&#8217;t present the magic number with a formula, but instead a block of text) I turned off my brain when reading that block of text.  Indeed both Scale and the original Besemmer CAC put S&amp;M in the denominator.  I do invert it &#8212; I think it makes more sense to say &#8220;how much did we spend to acquire a $1 of ARR&#8221; so I put the spend on top and the new ARR on the bottom. </p>
<p>I have revised the post to fix inconsistencies generated by this.</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="comment even thread-odd thread-alt depth-1 highlander-comment" id="li-comment-10291">
		<div id="comment-10291">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='http://www.thinkhr.com' rel='external nofollow' class='url'>Lisa Theunissen</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-10291">
				January 6, 2014 at 11:39 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=10291#respond' onclick='return addComment.moveForm( "comment-10291", "10291", "respond", "8827" )' aria-label='Reply to Lisa Theunissen'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>We have outside a few brokers that receive 1%-5% of the revenue from a small number of customers from contracts sold over a year ago. We don&#8217;t include this cost in S&amp;M. Internally we are debating if this is Cost of Revenue or if the cost should be netted against the revenue for a Net Revenue before Cost of Revenue. Obviously this could affect the outcome of a CAC calculation. </p>
<p>Any guidance you could provide is greatly appreciated.</p>
</div>

	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-davidkellogg bypostauthor odd alt depth-2 highlander-comment" id="li-comment-10380">
		<div id="comment-10380">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://davidkellogg.wordpress.com' rel='external nofollow' class='url'>Dave Kellogg</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-10380">
				January 17, 2014 at 8:51 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=10380#respond' onclick='return addComment.moveForm( "comment-10380", "10380", "respond", "8827" )' aria-label='Reply to Dave Kellogg'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Lisa,</p>
<p>This strikes me more as an accounting question, so I&#8217;m not the best person to answer it.  My initial reaction is if you are paying partners/channels any more to sell your solution then I would include that money as S&amp;M cost and ergo it would go in the CAC ratio.  </p>
<p>I suppose some firms would report the revenue net of the partner fees which would muck up the CAC calculation in this instance.</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2014/01/21/insight-ventures-periodic-tables-of-saas-sales-and-marketing-metrics/' rel='external nofollow' class='url'>Insight Ventures Periodic Tables of SaaS Sales and Marketing Metrics | Kellblog</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.enterpriseirregulars.com/71106/insight-ventures-periodic-tables-saas-sales-marketing-metrics/' rel='external nofollow' class='url'>Insight Ventures Periodic Tables of SaaS Sales and Marketing Metrics : Enterprise Irregulars</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2014/03/27/burn-baby-burn-a-look-at-the-box-s-1/' rel='external nofollow' class='url'>Burn Baby Burn: A Look at the Box S-1 | Kellblog</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.enterpriseirregulars.com/73321/burn-baby-burn-look-box-s-1/' rel='external nofollow' class='url'>Burn Baby Burn: A Look at the Box S-1 : Enterprise Irregulars</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://njdrmtrade.com/business/managing-startups-best-blog-posts-of-2013.html' rel='external nofollow' class='url'>Managing Startups: Best Blog Posts of 2013 | njdrmtrade.com</a></p>
	</li><!-- #comment-## -->
	<li class="comment even thread-even depth-1 highlander-comment" id="li-comment-22331">
		<div id="comment-22331">
		<div class="comment-author vcard">
			
			<cite class="fn">Dave</cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-22331">
				May 15, 2014 at 1:29 pm</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=22331#respond' onclick='return addComment.moveForm( "comment-22331", "22331", "respond", "8827" )' aria-label='Reply to Dave'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Great deep dive on CAC, thank you! Throughout the article, you mostly talked about ACV from new customers and also how to address churn / renewal rates. How do you think about CAC for upgrades? Say, a customer joints at $100/mo then three months later upgrades to $500/mo. However, spreadsheets still show the CAC as it related to the customer at $100/mo. Do you think CAC should include upgrades? or is this where you might suggest where tracking MRR reflects churn and upgrades?</p>
</div>

	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment byuser comment-author-davidkellogg bypostauthor odd alt depth-2 highlander-comment" id="li-comment-22336">
		<div id="comment-22336">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://davidkellogg.wordpress.com' rel='external nofollow' class='url'>Dave Kellogg</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-22336">
				May 15, 2014 at 1:40 pm</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=22336#respond' onclick='return addComment.moveForm( "comment-22336", "22336", "respond", "8827" )' aria-label='Reply to Dave Kellogg'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>In theory the CAC for an upsell should be calculated by the costs associated with that upsell.  So if a company has a dedicated upsell team, I&#8217;d put their costs in the CAC.  On the flip side if the upsell happens relatively quickly (think fast land-and-expand model) you can argue that the CAC should include all the ARR the customer signs up for in the first year.</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2014/05/15/the-box-s-1-delayed-ipo-and-the-genius-of-tien-zuo/' rel='external nofollow' class='url'>The Box S-1, Delayed IPO, and the Genius of Tien Zuo | Kellblog</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.enterpriseirregulars.com/74752/box-s-1-delayed-ipo-genius-tien-tzuo/' rel='external nofollow' class='url'>The Box S-1, Delayed IPO, and the Genius of Tien Tzuo : Enterprise Irregulars</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://studentforce.wordpress.com/2014/05/16/the-genius-of-saas-financials-explained/' rel='external nofollow' class='url'>The GENIUS of #SaaS Financials Explained | hireED4HigherEd</a></p>
	</li><!-- #comment-## -->
	<li class="comment even thread-odd thread-alt depth-1 highlander-comment" id="li-comment-24277">
		<div id="comment-24277">
		<div class="comment-author vcard">
			
			<cite class="fn">Brett</cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-24277">
				May 30, 2014 at 10:42 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=24277#respond' onclick='return addComment.moveForm( "comment-24277", "24277", "respond", "8827" )' aria-label='Reply to Brett'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Dave, I have a similar question to Lisa above &#8211; we usually include commissions earned and paid in the quarter as part of our S&amp;M costs.  This is obviously attributed to revenue added in previous Qs not in the current one in which we are calculating the CAC.  Should this be excluded somehow?</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-davidkellogg bypostauthor odd alt thread-even depth-1 highlander-comment" id="li-comment-25008">
		<div id="comment-25008">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://davidkellogg.wordpress.com' rel='external nofollow' class='url'>Dave Kellogg</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-25008">
				June 7, 2014 at 11:02 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=25008#respond' onclick='return addComment.moveForm( "comment-25008", "25008", "respond", "8827" )' aria-label='Reply to Dave Kellogg'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Brett, I&#8217;m not an accountant but I believe the trend is to &#8220;match&#8221; commissions costs with the revenue they generate.  Ergo, if you do that then your problem is solved as sales expense will reflect that amortization.  If you don&#8217;t do that, I think it&#8217;s hard to argue on one hand that you should expense commissions on the P&amp;L but not in the CAC &#8230; i.e., if you believe the right answer is matching (which it was I was taught in accounting 101) then go fix your sales expense and the CAC will follow.</p>
</div>

	</div><!-- #comment-##  -->

	<ul class="children">
	<li class="comment even depth-2 highlander-comment" id="li-comment-62979">
		<div id="comment-62979">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='http://www.satmetrix.com' rel='external nofollow' class='url'>Robert Promm</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-62979">
				July 15, 2015 at 5:18 pm</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=62979#respond' onclick='return addComment.moveForm( "comment-62979", "62979", "respond", "8827" )' aria-label='Reply to Robert Promm'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Dave, I think that your point is correct for excluding commissions that are applied to &gt;1st year in the CAC ratio as your cost of &#8220;acquisition&#8221; is technically only that attributable to the first year contract value.  This would be especially true if the payment of the 2nd year and future commission is deferred and contingent upon the customer actually renewing (if the contract requires affirmative confirmation of renewal).  Autorenewals are an interesting variation on the mutliyear contract.  They require a negative confirmation from the customer and therefore are more likely to renew but, technically, the customer can cancel as long as they meet the terms of notification of non-renewal.  My feeling is that commissions that apply beyond the first year should not be in CAC.  However, the accounting will not help you as GAAP.  You will never see a separate line item in the PL that highlights this.  If it were material, you might see it in some proforma view.  You probably want to segregate those commissions beyond the first year for internal metrics but I expect that you will be hard pressed to get that level of detail from others so that you can benchmark.  BTW, the &#8220;matching principle&#8221; is so yesterday. :-)  Very few companies defer commission expense and amortize it over the contract life.  Pacific Crest survey 2014 has a full 2/3rds of companies recognizing commission expense up front. Love your blog!</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
</ul><!-- .children -->
</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://soviders.org/the-high-road-to-building-an-enterprise-saas-company/' rel='external nofollow' class='url'>The high road to building an enterprise SaaS company | Soviders Tech</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://digise.com/the-high-road-to-building-an-enterprise-saas-company/' rel='external nofollow' class='url'>The high road to building an enterprise SaaS company | Digital Gadget dan Selular</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.khis.org/2014/06/the-high-road-to-building-an-enterprise-saas-company.html' rel='external nofollow' class='url'>The high road to building an enterprise SaaS company | Know How Is</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2014/07/30/the-ultimate-saas-metric-ltv-cac/' rel='external nofollow' class='url'>The Ultimate SaaS Metric: The Customer Lifetime Value to Customer Acquisition Cost Ratio (LTV/CAC) | Kellblog</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.enterpriseirregulars.com/76766/ultimate-saas-metric-customer-lifetime-value-customer-acquisition-cost-ratio-ltvcac/' rel='external nofollow' class='url'>The Ultimate SaaS Metric: The Customer Lifetime Value to Customer Acquisition Cost Ratio (LTV/CAC) : Enterprise Irregulars</a></p>
	</li><!-- #comment-## -->
	<li class="comment odd alt thread-odd thread-alt depth-1 highlander-comment" id="li-comment-33912">
		<div id="comment-33912">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='http://www.gainsight.com' rel='external nofollow' class='url'>Dan Steinman</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-33912">
				September 4, 2014 at 10:45 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=33912#respond' onclick='return addComment.moveForm( "comment-33912", "33912", "respond", "8827" )' aria-label='Reply to Dan Steinman'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Dave, great article.  Thanks for your detailed thinking on SaaS metrics.</p>
<p>I&#8217;m going to argue that the inclusion of ANY upsell/cross-sell revenue in your CAC numbers is misleading.  It would be tempting especially to include this if you had a separate Sales team executing on these transactions.  My argument is that the Customer Success team is largely responsible for all upsell/cross-sell even if they aren&#8217;t involved in the actual transaction.  They grease the skids with their daily efforts.  So, the inclusion of any add-on revenue without including associated Customer Success costs, creates misleading numbers.</p>
<p>This is also the reason I believe that Net Retention is the right metric by which to measure Customer Success regardless of whether they execute the renewal or upsell/cross-sell transactions.</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.baindaily.com/youre-the-boss-blog-why-it-makes-sense-for-some-companies-to-burn-cash/' rel='external nofollow' class='url'>You’re the Boss Blog: Why It Makes Sense for Some Companies to Burn Cash | Bain Daily</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://b2bcon.asia/the-high-road-to-building-an-enterprise-saas-company/' rel='external nofollow' class='url'>&raquo; The high road to building an enterprise SaaS company</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2015/04/19/one-more-time-what-drives-saas-company-valuation-growth/' rel='external nofollow' class='url'>One More Time: What Drives SaaS Company Valuation? Growth!! | Kellblog</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.enterpriseirregulars.com/88558/one-time-drives-saas-company-valuation-growth/' rel='external nofollow' class='url'>One More Time: What Drives SaaS Company Valuation? Growth!! - Enterprise Irregulars</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://jeffreybroer.com/2015/04/mentor-and-investor-email-updates/' rel='external nofollow' class='url'>Mentor and investor email updates | Jeffrey Broer</a></p>
	</li><!-- #comment-## -->
	<li class="comment byuser comment-author-davidkellogg bypostauthor even thread-even depth-1 highlander-comment" id="li-comment-63009">
		<div id="comment-63009">
		<div class="comment-author vcard">
			
			<cite class="fn"><a href='https://davidkellogg.wordpress.com' rel='external nofollow' class='url'>Dave Kellogg</a></cite>

			<span class="comment-meta commentmetadata">
				|
				<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#comment-63009">
				July 17, 2015 at 4:14 am</a>
					|
					<a rel='nofollow' class='comment-reply-link' href='https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/?replytocom=63009#respond' onclick='return addComment.moveForm( "comment-63009", "63009", "respond", "8827" )' aria-label='Reply to Dave Kellogg'>Reply</a>								</span><!-- .comment-meta .commentmetadata -->
		</div><!-- .comment-author .vcard -->
		
		<div class="comment-body"><p>Robert, you are indeed correct that sales expense is imho a GAAP term by default and that some companies amortize commissions whereas others take them up front.  This (along with treatment of customer success) is another great opportunity for apples/oranges CAC comparisons.  Whether sales costs should go to the renewal depends on who works on the renewal.  In many companies a dedicated customer success team does that work and in my mind if they are only renewing they should not be in the CAC ratio whereas if they are doing lots of upsell / new ARR generation then they should.</p>
</div>

	</div><!-- #comment-##  -->

	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://visage.co/culture-checkup-focus-content-creation/' rel='external nofollow' class='url'>Culture Checkup: How to Focus Your Content Creation</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2015/11/18/what-marketing-costs-should-be-included-in-cac-calculations/' rel='external nofollow' class='url'>What Marketing Costs Should be Included in CAC Calculations? | Kellblog</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://www.enterpriseirregulars.com/103453/marketing-costs-included-cac-calculations/' rel='external nofollow' class='url'>What Marketing Costs Should be Included in CAC Calculations? - Enterprise Irregulars</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://blog.captora.com/the-saas-3-0-imperative-managing-your-magic-growth-number/' rel='external nofollow' class='url'>The SaaS 3.0 Imperative: Managing Your Magic Growth Number</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://www.brandgfx.com/client-retention-costs-less-than-client-acquisition/' rel='external nofollow' class='url'>Client Retention Costs Less Than Client Acquisition | BRANDgfx Design and MarketingBRANDgfx Design and Marketing</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://www.realwiserealestate.com/6-super-simple-ideas-to-lower-customer-acquisition-cost-for-any-saas/' rel='external nofollow' class='url'>6 Super-Simple Ideas to Lower Customer Acquisition Cost for Any SaaS - Real Wise</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://macopo.com/6-super-simple-ideas-to-lower-customer-acquisition-cost-for-any-saas/' rel='external nofollow' class='url'>6 Super-Simple Ideas to Lower Customer Acquisition Cost for Any SaaS - Macopo</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://newsvideo.us/6-super-simple-ideas-to-lower-customer-acquisition-cost-for-any-saas/' rel='external nofollow' class='url'>6 Super-Simple Ideas to Lower Customer Acquisition Cost for Any SaaS | News Video</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://thedeadline.biz/6-super-simple-ideas-to-lower-customer-acquisition-cost-for-any-saas/' rel='external nofollow' class='url'>6 Super-Simple Ideas to Lower Customer Acquisition Cost for Any SaaS - The Deadline</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='http://fundavision.com/6-super-simple-ideas-to-lower-customer-acquisition-cost-for-any-saas/' rel='external nofollow' class='url'>FundaVision | Funding Accelerator Process | Create, Build and Fund your Business | 6 Super-Simple Ideas to Lower Customer Acquisition Cost for Any SaaS</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2016/03/17/cac-payback-period-the-most-misunderstood-saas-metric/' rel='external nofollow' class='url'>CAC Payback Period:  The Most Misunderstood SaaS Metric | Kellblog</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://www.enterpriseirregulars.com/105626/cac-payback-period-misunderstood-saas-metric/' rel='external nofollow' class='url'>CAC Payback Period:  The Most Misunderstood SaaS Metric - Enterprise Irregulars</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://oxfordvp.com/the-venn-diagram-that-will-change-how-you-fundraise/' rel='external nofollow' class='url'>Oxford Valuation Partners | The Venn Diagram That Will Change How you Fundraise</a></p>
	</li><!-- #comment-## -->
	<li class="post pingback">
		<p>Pingback: <a href='https://kellblog.com/2017/01/12/in-memory-analytics-the-other-kind-and-a-key-success-factor-for-your-career/' rel='external nofollow' class='url'>In-Memory Analytics: The Other Kind &#8211; A Key Success Factor for Your Career | Kellblog</a></p>
	</li><!-- #comment-## -->
		</ol>

		
	
					<div id="respond" class="comment-respond">
			<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/#respond" style="display:none;">Cancel reply</a></small></h3>				<form action="https://kellblog.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
					<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="66c0a6f100" /><input type="hidden" name="_wp_http_referer" value="/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">

	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" title="Guest">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" title="WordPress.com">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" title="Twitter">
					<span></span>
				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" title="Facebook">
					<span></span>
				</a>
			</li>
			<li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
	
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
				<p class="comment-form-posting-as pa-wordpress"><strong></strong> You are commenting using your WordPress.com account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
				<p class="comment-form-posting-as pa-twitter"><strong></strong> You are commenting using your Twitter account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
				<p class="comment-form-posting-as pa-facebook"><strong></strong> You are commenting using your Facebook account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Google+ photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
				<p class="comment-form-posting-as pa-googleplus"><strong></strong> You are commenting using your Google+ account. <span class="comment-form-log-out">(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)</span></p>
			</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>

<style type="text/css">
#respond .comment-form-avatar { display: none !important; }
#respond .comment-form-fields { margin-left: 0 !important; }
</style>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='8827' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="63ddfe4e98" /></p>
<input type="hidden" name="genseq" value="1486636159" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="233"/></p>				</form>
					</div><!-- #respond -->
		<div style="clear: both"></div>
</div><!-- #comments -->
	
	</div><!-- #content -->
</div><!-- #content-container -->


		
		<div id="primary" class="widget-area" role="complementary">
					<ul class="xoxo">

			<li id="text-3" class="widget-container widget_text">			<div class="textwidget"><div id="bio">

<img src="https://davidkellogg.files.wordpress.com/2015/01/1-1-dk-prof-sepia-001.jpg" alt="Dave Kellogg" style="float:left;border:1px solid #333;margin-right:10px;" />

<p>I'm Dave Kellogg, technology executive, investor, advisor, and blogger.   I'm also a hiker, oenophile, and fly fisher.</p>

I'm the CEO of <a href="http://www.hostanalytics.com">Host Analytics</a>, the leader in cloud-based enterprise performance management (EPM). </p><p>Previously, I was SVP/GM of Service Cloud at Salesforce and CEO at unstructured big data provider MarkLogic. Before that, I was CMO at Business Objects for nearly a decade as we grew from $30M to over $1B. I started my career in technical and product marketing positions at Ingres and Versant. </p>

<p>I love disruption, startups, and Silicon Valley and have had the pleasure of working in varied capacities with companies including Alation, Breeze, GainSight, MongoDB, and Tableau.  I currently sit on the boards of <a href="http://www.nuxeo.com">Nuxeo</a> (structured content managment) and <a href="http://www.granular.ag">Granular</a> (agtech) and previously sat on the board of big data firm Aster Data (big data) until its sale to Teradata.</p>

<p>I periodically speak to strategy and entrepreneurship classes at the Haas School of Business (UC Berkeley) and Hautes Études Commerciales de Paris (HEC).</p>
<p></p>
<a href="/frequently-asked-questions/">Read Frequently Asked Questions.</a>
<a href="mailto:davekellogg@mail.com">Contact Dave.</a>
</div></div>
		</li><li id="text-8" class="widget-container widget_text"><h3 class="widget-title">Updates</h3>			<div class="textwidget"><div id="updates">
<a id="link_rss" href="http://feeds.feedburner.com/kellblog">RSS</a>
<a id="link_twitter" href="http://twitter.com/kellblog">Twitter</a>
<a id="link_email" href="http://feedburner.google.com/fb/a/mailverify?uri=blogspot/FLvP" target="_blank">Email</a>
</div></div>
		</li><li id="top-posts-2" class="widget-container widget_top-posts"><h3 class="widget-title">Top Posts</h3><ul>				<li>
										<a href="https://kellblog.com/2015/03/08/career-development-what-it-really-means-to-be-a-manager-director-or-vp/" class="bump-view" data-bump-view="tp">
						Career Development:  What It Really Means to be a Manager, Director, or VP					</a>
									</li>
							<li>
										<a href="https://kellblog.com/2016/03/17/cac-payback-period-the-most-misunderstood-saas-metric/" class="bump-view" data-bump-view="tp">
						CAC Payback Period:  The Most Misunderstood SaaS Metric					</a>
									</li>
							<li>
										<a href="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" class="bump-view" data-bump-view="tp">
						The Customer Acquisition Cost (CAC) Ratio:  Another Subtle SaaS Metric					</a>
									</li>
							<li>
										<a href="https://kellblog.com/2010/09/10/more-emergent-strategies-groupon-greendot/" class="bump-view" data-bump-view="tp">
						More Emergent Strategies:  Groupon, Greendot					</a>
									</li>
							<li>
										<a href="https://kellblog.com/2013/10/04/measuring-saas-or-cloud-renewal-rates-way-more-than-meets-the-eye/" class="bump-view" data-bump-view="tp">
						Measuring SaaS Renewal Rates: Way More Than Meets the Eye					</a>
									</li>
			</ul></li><li id="twitter_timeline-2" class="widget-container widget_twitter_timeline"><h3 class="widget-title">Follow me on Twitter</h3><a class="twitter-timeline" data-height="400" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="5" data-lang="EN" data-widget-id="593441783524110336">My Tweets</a></li><li id="blog_subscription-3" class="widget-container widget_blog_subscription"><h3 class="widget-title"><label for="subscribe-field">Follow Blog via Email</label></h3>
				<form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8" id="subscribe-blog">
											<p>Enter your email address to follow this blog and receive notifications of new posts by email.</p>
						<p><input type="text" name="email" style="width: 95%; padding: 1px 2px" placeholder="Enter your email address" value="" id="subscribe-field"/></p>
					
					<p>
						<input type="hidden" name="action" value="subscribe"/>
						<input type="hidden" name="blog_id" value="11070789"/>
						<input type="hidden" name="source" value="https://kellblog.com/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/"/>
						<input type="hidden" name="sub-type" value="widget"/>
						<input type="hidden" name="redirect_fragment" value="blog_subscription-3" />
						<input type="hidden" id="_wpnonce" name="_wpnonce" value="e02a870e41" />						<input type="submit" value="Follow" />
					</p>
				</form>
			
</li><li id="text-9" class="widget-container widget_text"><h3 class="widget-title">Best of Kellblog</h3>			<div class="textwidget"><a href="http://www.kellblog.com/best-of-kellblog/">Read My Top Favorite Posts</a></div>
		</li><li id="categories-4" class="widget-container widget_categories"><h3 class="widget-title">Categories</h3><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="222591380">Adaptive Insights</option>
	<option class="level-0" value="521">Advertising</option>
	<option class="level-0" value="11287">Agile</option>
	<option class="level-0" value="21446220">AgTech</option>
	<option class="level-0" value="139620">Analyst Relations</option>
	<option class="level-0" value="11453">Analytics</option>
	<option class="level-0" value="75685968">Anaplan</option>
	<option class="level-0" value="6758">Awards</option>
	<option class="level-0" value="19316">BI</option>
	<option class="level-0" value="2075170">Big Data</option>
	<option class="level-0" value="91">Blogging</option>
	<option class="level-0" value="79128">Board</option>
	<option class="level-0" value="8260">Branding</option>
	<option class="level-0" value="45854">Bubble</option>
	<option class="level-0" value="36951">Budgeting</option>
	<option class="level-0" value="117765">Business Objects</option>
	<option class="level-0" value="616575">CAC</option>
	<option class="level-0" value="10406">CEO</option>
	<option class="level-0" value="53067">CFO</option>
	<option class="level-0" value="14526">change</option>
	<option class="level-0" value="160581095">Chasm Crossing</option>
	<option class="level-0" value="104802">churn</option>
	<option class="level-0" value="69816">Cloud</option>
	<option class="level-0" value="7742">Communications</option>
	<option class="level-0" value="2528">Community</option>
	<option class="level-0" value="113">Content</option>
	<option class="level-0" value="4259">CRM</option>
	<option class="level-0" value="1210871">CSAT</option>
	<option class="level-0" value="1098">Culture</option>
	<option class="level-0" value="7344">CX</option>
	<option class="level-0" value="9258636">CXM</option>
	<option class="level-0" value="867">Data Mining</option>
	<option class="level-0" value="21818323">Data Science</option>
	<option class="level-0" value="475">Database</option>
	<option class="level-0" value="67837">Decision Making</option>
	<option class="level-0" value="4619">Disruption</option>
	<option class="level-0" value="143933">Documentum</option>
	<option class="level-0" value="138102">ECM</option>
	<option class="level-0" value="650430">Endeca</option>
	<option class="level-0" value="400734">Enterprise Search</option>
	<option class="level-0" value="99155">Enterprise Software</option>
	<option class="level-0" value="183">Entrepreneurship</option>
	<option class="level-0" value="662352">EPM</option>
	<option class="level-0" value="81819">Facebook</option>
	<option class="level-0" value="3233415">Fast Search</option>
	<option class="level-0" value="4269">Finance</option>
	<option class="level-0" value="31435685">Finance Transformation</option>
	<option class="level-0" value="7489">Financial</option>
	<option class="level-0" value="691215">FPA</option>
	<option class="level-0" value="4704">France</option>
	<option class="level-0" value="328920">Gartner</option>
	<option class="level-0" value="81">Google</option>
	<option class="level-0" value="75701">Grateful Dead</option>
	<option class="level-0" value="3251196">Hadoop</option>
	<option class="level-0" value="113932">Hiring</option>
	<option class="level-0" value="27875893">Host Analytics</option>
	<option class="level-0" value="22518">HP</option>
	<option class="level-0" value="39956">HR</option>
	<option class="level-0" value="32744">IBM</option>
	<option class="level-0" value="105388">In-Memory</option>
	<option class="level-0" value="3054">India</option>
	<option class="level-0" value="186">Innovation</option>
	<option class="level-0" value="1310359">Innovator&#8217;s Dilemma</option>
	<option class="level-0" value="310880">Innumeracy</option>
	<option class="level-0" value="14066">Intelligence</option>
	<option class="level-0" value="18477">IPO</option>
	<option class="level-0" value="7885">Leadership</option>
	<option class="level-0" value="18960">M&amp;A</option>
	<option class="level-0" value="2151166">Magic Quadrant</option>
	<option class="level-0" value="4236">Management</option>
	<option class="level-0" value="175">Marketing</option>
	<option class="level-0" value="4232101">MarkLogic</option>
	<option class="level-0" value="292">Media</option>
	<option class="level-0" value="7092">Metrics</option>
	<option class="level-0" value="637">Microsoft</option>
	<option class="level-0" value="258395">MicroStrategy</option>
	<option class="level-0" value="19878">Modeling</option>
	<option class="level-0" value="472999">Moore&#8217;s Law</option>
	<option class="level-0" value="3747">Newspaper</option>
	<option class="level-0" value="22319505">NoSQL</option>
	<option class="level-0" value="25">Open Source</option>
	<option class="level-0" value="3766">Oracle</option>
	<option class="level-0" value="811609">OSINT</option>
	<option class="level-0" value="3812524">Palantir</option>
	<option class="level-0" value="4599">Planning</option>
	<option class="level-0" value="90941">Positioning</option>
	<option class="level-0" value="635">PR</option>
	<option class="level-0" value="22707">Predictions</option>
	<option class="level-0" value="51999">Pricing</option>
	<option class="level-0" value="3279">Privacy</option>
	<option class="level-0" value="29172">Private Equity</option>
	<option class="level-0" value="9719">process</option>
	<option class="level-0" value="1568">Randomness</option>
	<option class="level-0" value="282303">RDBMS</option>
	<option class="level-0" value="8452">Recruiting</option>
	<option class="level-0" value="17927">SaaS</option>
	<option class="level-0" value="7094">Sales</option>
	<option class="level-0" value="1084675">SAP AG</option>
	<option class="level-0" value="2373">Search</option>
	<option class="level-0" value="5655">Semantic</option>
	<option class="level-0" value="479814">Sequoia</option>
	<option class="level-0" value="49875">Silicon Valley</option>
	<option class="level-0" value="3457">Social</option>
	<option class="level-0" value="1652">social networking</option>
	<option class="level-0" value="26658">Solutions</option>
	<option class="level-0" value="20429">Startups</option>
	<option class="level-0" value="14543346">Stonebraker</option>
	<option class="level-0" value="8553">Strategy</option>
	<option class="level-0" value="429">Sun</option>
	<option class="level-0" value="1092">Surveys</option>
	<option class="level-0" value="852300">Tableau</option>
	<option class="level-0" value="16931">TechCrunch</option>
	<option class="level-0" value="38262249">Technology laws</option>
	<option class="level-0" value="621903">Terms of Service</option>
	<option class="level-0" value="2495437">text analytics</option>
	<option class="level-0" value="30057625">thick middle tier</option>
	<option class="level-0" value="57610">Trust</option>
	<option class="level-0" value="599182">Twitter</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="39336813">Unicorn</option>
	<option class="level-0" value="2789202">Unstructured</option>
	<option class="level-0" value="37820">Valuation</option>
	<option class="level-0" value="202">Venture Capital</option>
	<option class="level-0" value="3161794">Web 2.0</option>
	<option class="level-0" value="11601">Wisdom of Crowds</option>
	<option class="level-0" value="6852">XML</option>
	<option class="level-0" value="36973">XQuery</option>
</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			location.href = "https://kellblog.com/?cat=" + dropdown.options[ dropdown.selectedIndex ].value;
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

</li><li id="search-3" class="widget-container widget_search"><h3 class="widget-title">Search Kellblog</h3><form role="search" method="get" id="searchform" class="searchform" action="https://kellblog.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></li><li id="archives-3" class="widget-container widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://kellblog.com/2017/01/'> January 2017 </option>
	<option value='https://kellblog.com/2016/12/'> December 2016 </option>
	<option value='https://kellblog.com/2016/11/'> November 2016 </option>
	<option value='https://kellblog.com/2016/10/'> October 2016 </option>
	<option value='https://kellblog.com/2016/09/'> September 2016 </option>
	<option value='https://kellblog.com/2016/08/'> August 2016 </option>
	<option value='https://kellblog.com/2016/07/'> July 2016 </option>
	<option value='https://kellblog.com/2016/06/'> June 2016 </option>
	<option value='https://kellblog.com/2016/05/'> May 2016 </option>
	<option value='https://kellblog.com/2016/04/'> April 2016 </option>
	<option value='https://kellblog.com/2016/03/'> March 2016 </option>
	<option value='https://kellblog.com/2016/02/'> February 2016 </option>
	<option value='https://kellblog.com/2016/01/'> January 2016 </option>
	<option value='https://kellblog.com/2015/12/'> December 2015 </option>
	<option value='https://kellblog.com/2015/11/'> November 2015 </option>
	<option value='https://kellblog.com/2015/10/'> October 2015 </option>
	<option value='https://kellblog.com/2015/09/'> September 2015 </option>
	<option value='https://kellblog.com/2015/08/'> August 2015 </option>
	<option value='https://kellblog.com/2015/07/'> July 2015 </option>
	<option value='https://kellblog.com/2015/06/'> June 2015 </option>
	<option value='https://kellblog.com/2015/05/'> May 2015 </option>
	<option value='https://kellblog.com/2015/04/'> April 2015 </option>
	<option value='https://kellblog.com/2015/03/'> March 2015 </option>
	<option value='https://kellblog.com/2015/02/'> February 2015 </option>
	<option value='https://kellblog.com/2015/01/'> January 2015 </option>
	<option value='https://kellblog.com/2014/12/'> December 2014 </option>
	<option value='https://kellblog.com/2014/11/'> November 2014 </option>
	<option value='https://kellblog.com/2014/10/'> October 2014 </option>
	<option value='https://kellblog.com/2014/09/'> September 2014 </option>
	<option value='https://kellblog.com/2014/08/'> August 2014 </option>
	<option value='https://kellblog.com/2014/07/'> July 2014 </option>
	<option value='https://kellblog.com/2014/06/'> June 2014 </option>
	<option value='https://kellblog.com/2014/05/'> May 2014 </option>
	<option value='https://kellblog.com/2014/04/'> April 2014 </option>
	<option value='https://kellblog.com/2014/03/'> March 2014 </option>
	<option value='https://kellblog.com/2014/02/'> February 2014 </option>
	<option value='https://kellblog.com/2014/01/'> January 2014 </option>
	<option value='https://kellblog.com/2013/12/'> December 2013 </option>
	<option value='https://kellblog.com/2013/11/'> November 2013 </option>
	<option value='https://kellblog.com/2013/10/'> October 2013 </option>
	<option value='https://kellblog.com/2013/09/'> September 2013 </option>
	<option value='https://kellblog.com/2013/08/'> August 2013 </option>
	<option value='https://kellblog.com/2013/07/'> July 2013 </option>
	<option value='https://kellblog.com/2013/06/'> June 2013 </option>
	<option value='https://kellblog.com/2013/05/'> May 2013 </option>
	<option value='https://kellblog.com/2013/04/'> April 2013 </option>
	<option value='https://kellblog.com/2012/03/'> March 2012 </option>
	<option value='https://kellblog.com/2012/02/'> February 2012 </option>
	<option value='https://kellblog.com/2012/01/'> January 2012 </option>
	<option value='https://kellblog.com/2011/12/'> December 2011 </option>
	<option value='https://kellblog.com/2011/11/'> November 2011 </option>
	<option value='https://kellblog.com/2011/10/'> October 2011 </option>
	<option value='https://kellblog.com/2011/09/'> September 2011 </option>
	<option value='https://kellblog.com/2011/08/'> August 2011 </option>
	<option value='https://kellblog.com/2011/07/'> July 2011 </option>
	<option value='https://kellblog.com/2011/06/'> June 2011 </option>
	<option value='https://kellblog.com/2011/05/'> May 2011 </option>
	<option value='https://kellblog.com/2011/04/'> April 2011 </option>
	<option value='https://kellblog.com/2011/03/'> March 2011 </option>
	<option value='https://kellblog.com/2011/02/'> February 2011 </option>
	<option value='https://kellblog.com/2011/01/'> January 2011 </option>
	<option value='https://kellblog.com/2010/12/'> December 2010 </option>
	<option value='https://kellblog.com/2010/11/'> November 2010 </option>
	<option value='https://kellblog.com/2010/10/'> October 2010 </option>
	<option value='https://kellblog.com/2010/09/'> September 2010 </option>
	<option value='https://kellblog.com/2010/08/'> August 2010 </option>
	<option value='https://kellblog.com/2010/07/'> July 2010 </option>
	<option value='https://kellblog.com/2010/06/'> June 2010 </option>
	<option value='https://kellblog.com/2010/05/'> May 2010 </option>
	<option value='https://kellblog.com/2010/04/'> April 2010 </option>
	<option value='https://kellblog.com/2010/03/'> March 2010 </option>
	<option value='https://kellblog.com/2010/02/'> February 2010 </option>
	<option value='https://kellblog.com/2010/01/'> January 2010 </option>
	<option value='https://kellblog.com/2009/12/'> December 2009 </option>
	<option value='https://kellblog.com/2009/11/'> November 2009 </option>
	<option value='https://kellblog.com/2009/10/'> October 2009 </option>
	<option value='https://kellblog.com/2009/09/'> September 2009 </option>
	<option value='https://kellblog.com/2009/08/'> August 2009 </option>
	<option value='https://kellblog.com/2009/07/'> July 2009 </option>
	<option value='https://kellblog.com/2009/06/'> June 2009 </option>
	<option value='https://kellblog.com/2009/05/'> May 2009 </option>
	<option value='https://kellblog.com/2009/04/'> April 2009 </option>
	<option value='https://kellblog.com/2009/03/'> March 2009 </option>
	<option value='https://kellblog.com/2009/02/'> February 2009 </option>
	<option value='https://kellblog.com/2009/01/'> January 2009 </option>
	<option value='https://kellblog.com/2008/12/'> December 2008 </option>
	<option value='https://kellblog.com/2008/11/'> November 2008 </option>
	<option value='https://kellblog.com/2008/10/'> October 2008 </option>
	<option value='https://kellblog.com/2008/09/'> September 2008 </option>
	<option value='https://kellblog.com/2008/08/'> August 2008 </option>
	<option value='https://kellblog.com/2008/07/'> July 2008 </option>
	<option value='https://kellblog.com/2008/06/'> June 2008 </option>
	<option value='https://kellblog.com/2008/05/'> May 2008 </option>
	<option value='https://kellblog.com/2008/04/'> April 2008 </option>
	<option value='https://kellblog.com/2008/03/'> March 2008 </option>
	<option value='https://kellblog.com/2008/02/'> February 2008 </option>
	<option value='https://kellblog.com/2008/01/'> January 2008 </option>
	<option value='https://kellblog.com/2007/12/'> December 2007 </option>
	<option value='https://kellblog.com/2007/11/'> November 2007 </option>
	<option value='https://kellblog.com/2007/10/'> October 2007 </option>
	<option value='https://kellblog.com/2007/09/'> September 2007 </option>
	<option value='https://kellblog.com/2007/08/'> August 2007 </option>
	<option value='https://kellblog.com/2007/07/'> July 2007 </option>
	<option value='https://kellblog.com/2007/06/'> June 2007 </option>
	<option value='https://kellblog.com/2007/05/'> May 2007 </option>
	<option value='https://kellblog.com/2007/04/'> April 2007 </option>
	<option value='https://kellblog.com/2007/03/'> March 2007 </option>
	<option value='https://kellblog.com/2007/02/'> February 2007 </option>
	<option value='https://kellblog.com/2007/01/'> January 2007 </option>
	<option value='https://kellblog.com/2006/12/'> December 2006 </option>
	<option value='https://kellblog.com/2006/11/'> November 2006 </option>
	<option value='https://kellblog.com/2006/10/'> October 2006 </option>
	<option value='https://kellblog.com/2006/09/'> September 2006 </option>
	<option value='https://kellblog.com/2006/08/'> August 2006 </option>
	<option value='https://kellblog.com/2006/07/'> July 2006 </option>
	<option value='https://kellblog.com/2006/06/'> June 2006 </option>
	<option value='https://kellblog.com/2006/05/'> May 2006 </option>
	<option value='https://kellblog.com/2006/04/'> April 2006 </option>
	<option value='https://kellblog.com/2006/03/'> March 2006 </option>
	<option value='https://kellblog.com/2005/12/'> December 2005 </option>
	<option value='https://kellblog.com/2005/11/'> November 2005 </option>
	<option value='https://kellblog.com/2005/10/'> October 2005 </option>
	<option value='https://kellblog.com/2005/09/'> September 2005 </option>
	<option value='https://kellblog.com/2005/08/'> August 2005 </option>

		</select>
		</li><li id="text-10" class="widget-container widget_text">			<div class="textwidget"><div id="blogDescription">
This blog is written by Dave Kellogg and covers a mix of topics including performance management, analytics, big data, and social technologies along with commentary on Silicon Valley, venture capital, and the business of software.
</div></div>
		</li>			</ul>
		</div><!-- #primary .widget-area -->

		
			</div><!-- #content-box -->

	<div id="footer" role="contentinfo">
		
<div id="footer-widget-area" role="complementary">

	<div id="first" class="widget-area">
		<ul class="xoxo">
			<li id="text-2" class="widget-container widget_text">			<div class="textwidget"><a rel="license" href="http://creativecommons.org/licenses/by-nc/4.0/"><img alt="Creative Commons License" style="border-width:0;" src="https://i.creativecommons.org/l/by-nc/4.0/80x15.png" /></a><br /><span>Kellblog</span> by <span>Dave Kellogg</span> is licensed under a <a rel="license" href="http://creativecommons.org/licenses/by-nc/4.0/">Creative Commons Attribution-NonCommercial 4.0 International License</a>. </div>
		</li>		</ul>
	</div><!-- #first .widget-area -->




</div><!-- #footer-widget-area -->
		<div id="colophon">
			<span class="generator-link"><a href="https://wordpress.com/?ref=footer_blog">Blog at WordPress.com.</a></span>
					</div><!-- #colophon -->
	</div><!-- #footer -->

</div><!-- #container -->

<!--  -->
		<script type="text/javascript">
			!function(d,s,id){
				var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';
				if(!d.getElementById(id)){
					js=d.createElement(s);
					js.id=id;js.src=p+"://platform.twitter.com/widgets.js";
					fjs.parentNode.insertBefore(js,fjs);
				}
			}(document,"script","twitter-wjs");
		</script>
			<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/davidkellogg.wordpress.com\/public.api\/connect\/?action=request","logoutURL":"https:\/\/davidkellogg.wordpress.com\/wp-login.php?action=logout&_wpnonce=1d50b2bf70","homeURL":"https:\/\/kellblog.com\/","postID":"8827","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"0","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1479964158j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="11070789" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://kellblog.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Kellblog" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="80f77e4ac0" /><input type="hidden" name="_wp_http_referer" value="/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/kellblog.com\/2013\/12\/01\/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric\/":8827};
	</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-twitter' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-linkedin' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
		});
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
							<script type="text/javascript">
				jQuery(document).on('ready', function(){
					jQuery('body').on('click', 'a.share-pinterest', function(e){
						e.preventDefault();
						// Load Pinterest Bookmarklet code
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = window.location.protocol + "//assets.pinterest.com/js/pinmarklet.js?r=" + ( Math.random() * 99999999 );
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
						// Trigger Stats
						var s = document.createElement("script");
						s.type = "text/javascript";
						s.src = this + ( this.toString().indexOf( '?' ) ? '&' : '?' ) + 'js_only=1';
						var x = document.getElementsByTagName("script")[0];
						x.parentNode.insertBefore(s, x);
					});
				});
			</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2013/12/01/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			<div class="recaptcha" id="sharing_recaptcha"></div><input type="hidden" name="recaptcha_public_key" id="recaptcha_public_key" value="6LcYW8MSAAAAADBAuEH9yaPcF7lWh11Iq62ZKtoo" />
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='https://s1.wp.com/wp-content/mu-plugins/akismet-3.0/_inc/form.js?m=1404442431h'></script>
<link rel='stylesheet' id='all-css-0-3' href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1481571546h' type='text/css' media='all' />
<!--[if lte IE 8]>
<link rel='stylesheet' id='jetpack-carousel-ie8fix-css'  href='https://s1.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel-ie8fix.css?m=1412618825h&#038;ver=20121024' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"11070789","siteName":"Kellblog","siteURL":"https:\/\/kellblog.com","icon":"<img alt='' src='https:\/\/secure.gravatar.com\/blavatar\/8ecfcffdb3cd0948a0c38207c0ca38d6?s=50&d=https%3A%2F%2Fs1.wp.com%2Fi%2Flogo%2Fwpcom-gray-white.png' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/coraline","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/davidkellogg.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fkellblog.com%2F2013%2F12%2F01%2Fthe-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric%2F","themeURL":"","xhrURL":"https:\/\/kellblog.com\/wp-admin\/admin-ajax.php","nonce":"de295070ed","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"e02a870e41\" \/>","referer":"https:\/\/kellblog.com\/2013\/12\/01\/the-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric\/","canFollow":"1","statusMessage":"","customizeLink":"https:\/\/davidkellogg.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fdavidkellogg.wordpress.com%2F2013%2F12%2F01%2Fthe-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric%2F","postID":"8827","shortlink":"http:\/\/wp.me\/pKs17-2in","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/kellblog.com\/8827","statsLink":"https:\/\/wordpress.com\/stats\/post\/8827\/kellblog.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Coraline","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in the Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 7,734 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/davidkellogg.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fkellblog.com%2F2013%2F12%2F01%2Fthe-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric%2F\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/kellblog.com\/wp-admin\/admin-ajax.php","nonce":"159f2d8841","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/davidkellogg.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fkellblog.com%2F2013%2F12%2F01%2Fthe-customer-acquisition-cost-cac-ratio-another-subtle-saas-metric%2F","blog_id":"11070789","local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=11070789&v=wpcom&tz=-8&user_id=0&subd=davidkellogg","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??-eJx9j0sOwjAMRC9EaiFaxAZxlpAa6pAfdlLg9qQShS5QV7ZmPM82PJIyMWQMGaxAjyMZTM/GygYWli8quXKlIODohgL3ggUHHXqHPA9TMK701awgE72vQcWY3KvxFFaIuq++OmsGryUj107FEZlpgn21NYLJFMNE+Hb/jpL0u2Op2/oNvz6lWU792WU0xyLowGJO2tzULKxkUpSsLk4TgwyaKVznWkMnf9y2h65r2/2us2/zZZX/'></script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>	<script type="text/javascript">
	var skimlinks_pub_id = "725X584219"
	var skimlinks_sitename = "davidkellogg.wordpress.com";
	</script>
	<script type="text/javascript" defer src="https://s.skimresources.com/js/725X1342.skimlinks.js"></script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20170206#ver=20170206' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
		<script>
			var _comscore = _comscore || [];
			_comscore.push({
				c1: "2",
				c2: "7518284"
			});
			(function() {
				var s = document.createElement("script"),
					el = document.getElementsByTagName("script")[0];
				s.defer = true;
				s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
				el.parentNode.insertBefore(s, el);
			})();
		</script>
		<noscript>
			<p class="robots-nocontent"><img src="https://sb.scorecardresearch.com/p?c1=2&c2=7518284&c3=&c4=&c5=&c6=&c15=&cv=2.0&cj=1" alt="" style="display:none;" width="1" height="1" /></p>
		</noscript><script src="//stats.wp.com/w.js?56" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'11070789','blog_tz':'-8','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'11070789','v':'wpcom','tz':'-8','user_id':'0','post':'8827','subd':'davidkellogg'}]);
_stq.push(['extra', {'crypt':'UE5XaGUuOTlwaD85flAmcm1mcmZsaDhkV11YdWtpP0NsWnVkPS9sL0ViLndld3BuVT01Unp2dX5PUFNWV0hkNjh1K1hJK01OPT9mWXdSdksudlg9d0k3NEhRRXg1LW5WS1AvJjdYXUFkYVJ0MU5uRHZbRS03Ty1rTTFfSUV4MXx3VjdBaFhPSWldX0UtLUk5RkR8RHxES11LemhsLlY2PTFaSTZWW3JmeW1Ga340RWJqNCt3QV1EbGwmOWF4JnNoelV5MlVsXW5+SWI9WTQvdVJrX2NSeUFWcFU0d3hSLi9rRy9NQk5fX21KMCVXREVENHouSHBYZXlHQjdvbElrb1JzM04tcTBpfit4b3ZQblR0QStIbmwsVThyfmdkTmcuQWhqfEJqTTY1aGItUDdFP0pkSXgwfGdkREt4dk1xajVtMnw='}]);
_stq.push([ 'clickTrackerInit', '11070789', '8827' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>