<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en">
<![endif]-->
<!--[if (!IE)]><!-->
<html lang="en">
<!--<![endif]-->

<head>
<meta charset="UTF-8" />
<title>Kellblog&#8217;s Greatest Hits 2016-2019 per the Appealie SaaS Awards | Kellblog</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://kellblog.com/xmlrpc.php" />
<meta name="google-site-verification" content="1umdHs4KavW-E9iZAxU6ptoXzxYBMXUdSa2jwD36Ebk" />

<!-- Async WordPress.com Remote Login -->
<script id="wpcom_remote_login_js">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</script>
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//davidkellogg.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Kellblog &raquo; Feed" href="https://kellblog.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kellblog &raquo; Comments Feed" href="https://kellblog.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Kellblog &raquo; Kellblog&#8217;s Greatest Hits 2016-2019 per the Appealie SaaS&nbsp;Awards Comments Feed" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/feed/" />
	<script type="text/javascript">
		/* <![CDATA[ */
		function addLoadEvent(func) {
			var oldonload = window.onload;
			if (typeof window.onload != 'function') {
				window.onload = func;
			} else {
				window.onload = function () {
					oldonload();
					func();
				}
			}
		}
		/* ]]> */
	</script>
			<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/72x72\/","ext":".png","svgUrl":"https:\/\/s0.wp.com\/wp-content\/mu-plugins\/wpcom-smileys\/twemoji\/2\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/s2.wp.com\/wp-includes\/js\/wp-emoji-release.min.js?m=1556893897h&ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0-1' href='https://s0.wp.com/_static/??-eJyNUltywjAMvFAdAS3Qn07PYifCEdixx3aGcvvKcSjl5eEn0Sq7Wj0CRy9aNyQcEthReDNqGiIENDJhJ7yL6QY1bYxv8Fhm6IAR9pi8bA9iQnf0M1ePDBUGzV8CwqZZNQtQI5kOlHGTXAUZThDTyeALZSZVhETDAcMZlYL1Eq2byctm+c5NdBRT6SE2RTlVearfjcaISAkFdsT2et4HLJotTDvjWWIqLZXqt9naUvN6OG+9TJlh2USiQcu0muxInUY+HlPmWCT8qUqs35yNctjLvIGahWe2UMoHjFHw09JoReq5t3tdSYMfVZ5IGhrwyV0eMWloC1tMpq8Mnpyf/99/NgSDS8Sq+BfUaml0gu8jE7nhCoidkRRq0oB8Wc2hnk5wgTWRbHNxJcMlqtHzeKUTiL0M2Wt+11TRtSQNj6LdNXh2if4DtHFKmkz4tl/L9Wa7/Vxv16v9L5Wgl+4=?cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s1.wp.com/_static/??-eJyFj+EKAiEQhF8oT+Lw6E/0LOZtsqarudpRT59C/eg4ChaWYT9mZuWSBJLxdQaWrs2tQn681+B4J38BIqDNusAQkD6wiVSASmdT5BKAWVvYuIZ4Rg+iMuQGUGkxl7jmQhXJV4vEMoNvUbPoriu14f79CNIdYfmLOShJm6vIwPjsnU/huFfqMKppUqN7ATNIcHo='></script>
<link rel='stylesheet' id='all-css-0-2' href='https://s0.wp.com/wp-content/mu-plugins/highlander-comments/style.css?m=1530132353h&cssminify=yes' type='text/css' media='all' />
<!--[if lt IE 8]>
<link rel='stylesheet' id='highlander-comments-ie7-css'  href='https://s2.wp.com/wp-content/mu-plugins/highlander-comments/style-ie7.css?m=1351637563h&#038;ver=20110606' type='text/css' media='all' />
<![endif]-->
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://davidkellogg.wordpress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://s1.wp.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='If Rebranding’s the Answer, What was the&nbsp;Question?' href='https://kellblog.com/2019/08/31/if-rebrandings-the-answer-what-was-the-question/' />
<meta name="generator" content="WordPress.com" />
<link rel="canonical" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" />
<link rel='shortlink' href='https://wp.me/pKs17-3GR' />
<link rel="alternate" type="application/json+oembed" href="https://public-api.wordpress.com/oembed/?format=json&amp;url=https%3A%2F%2Fkellblog.com%2F2019%2F09%2F13%2Fkellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards%2F&amp;for=wpcom-auto-discovery" /><link rel="alternate" type="application/xml+oembed" href="https://public-api.wordpress.com/oembed/?format=xml&amp;url=https%3A%2F%2Fkellblog.com%2F2019%2F09%2F13%2Fkellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards%2F&amp;for=wpcom-auto-discovery" />
<!-- Jetpack Open Graph Tags -->
<meta property="og:type" content="article" />
<meta property="og:title" content="Kellblog&#8217;s Greatest Hits 2016-2019 per the Appealie SaaS Awards" />
<meta property="og:url" content="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" />
<meta property="og:description" content="I&#8217;ll be speaking at the APPEALIE 2019 SaaS Conference and Awards in San Francisco on September 25th and I noticed that in their promotions the folks at APPEALIE had assembled their own Kellbl…" />
<meta property="article:published_time" content="2019-09-13T15:32:10+00:00" />
<meta property="article:modified_time" content="2019-09-13T06:34:28+00:00" />
<meta property="og:site_name" content="Kellblog" />
<meta property="og:image" content="https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg" />
<meta property="og:image:width" content="500" />
<meta property="og:image:height" content="250" />
<meta property="og:locale" content="en_US" />
<meta name="twitter:creator" content="@kellblog" />
<meta name="twitter:site" content="@kellblog" />
<meta name="twitter:text:title" content="Kellblog&#8217;s Greatest Hits 2016-2019 per the Appealie SaaS&nbsp;Awards" />
<meta name="twitter:image" content="https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=640" />
<meta name="twitter:card" content="summary_large_image" />
<meta property="article:publisher" content="https://www.facebook.com/WordPresscom" />

<!-- End Jetpack Open Graph Tags -->
<link rel='openid.server' href='https://kellblog.com/?openidserver=1' />
<link rel='openid.delegate' href='https://kellblog.com/' />
<link rel="search" type="application/opensearchdescription+xml" href="https://kellblog.com/osd.xml" title="Kellblog" />
<link rel="search" type="application/opensearchdescription+xml" href="https://s1.wp.com/opensearch.xml" title="WordPress.com" />
<meta name="application-name" content="Kellblog" /><meta name="msapplication-window" content="width=device-width;height=device-height" /><meta name="msapplication-tooltip" content="The official blog of Dave Kellogg" /><meta name="msapplication-task" content="name=Subscribe;action-uri=https://kellblog.com/feed/;icon-uri=https://davidkellogg.files.wordpress.com/2018/08/cropped-dk-headshot-bio-untouched-keffer-1-slate.png?w=16" /><meta name="msapplication-task" content="name=Sign up for a free blog;action-uri=http://wordpress.com/signup/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Support;action-uri=http://support.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="msapplication-task" content="name=WordPress.com Forums;action-uri=http://forums.wordpress.com/;icon-uri=https://s1.wp.com/i/favicon.ico" /><meta name="description" content="I&#039;ll be speaking at the APPEALIE 2019 SaaS Conference and Awards in San Francisco on September 25th and I noticed that in their promotions the folks at APPEALIE had assembled their own Kellblog&#039;s Greatest Hits album from 2016 to 2019, complete with its own cover art. When I looked at the posts they picked, I thought&hellip;" />
<link rel="amphtml" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/amp/"><link rel="icon" href="https://davidkellogg.files.wordpress.com/2018/08/cropped-dk-headshot-bio-untouched-keffer-1-slate.png?w=32" sizes="32x32" />
<link rel="icon" href="https://davidkellogg.files.wordpress.com/2018/08/cropped-dk-headshot-bio-untouched-keffer-1-slate.png?w=192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://davidkellogg.files.wordpress.com/2018/08/cropped-dk-headshot-bio-untouched-keffer-1-slate.png?w=180" />
<meta name="msapplication-TileImage" content="https://davidkellogg.files.wordpress.com/2018/08/cropped-dk-headshot-bio-untouched-keffer-1-slate.png?w=270" />
		<link rel="stylesheet" id="custom-css-css" type="text/css" href="https://s1.wp.com/?custom-css=1&#038;csblog=Ks17&#038;cscache=6&#038;csrev=49" />
		</head>

<body class="post-template-default single single-post postid-14189 single-format-standard mp6 customizer-styles-applied two-column content-sidebar highlander-enabled highlander-light">
<div id="container" class="hfeed contain">
	<div id="header">
		<div id="masthead" role="banner">
						<div id="site-title">
				<span>
					<a href="https://kellblog.com/" title="Kellblog" rel="home">Kellblog</a>
				</span>
			</div>
			<div id="site-description">The official blog of Dave Kellogg</div>
		</div><!-- #masthead -->

		<div id="access" role="navigation">
		  			<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
						<div class="menu"><ul>
<li ><a href="https://kellblog.com/">Home</a></li><li class="page_item page-item-6950"><a href="https://kellblog.com/best-of-kellblog/">Best of Kellblog</a></li>
<li class="page_item page-item-6948"><a href="https://kellblog.com/frequently-asked-questions/">Frequently Asked Questions</a></li>
</ul></div>
		</div><!-- #access -->

		<div id="branding">
					</div><!-- #branding -->
	</div><!-- #header -->

	<div id="content-box">

<div id="content-container">
	<div id="content" role="main">

	
		<div id="nav-above" class="navigation">
			<div class="nav-previous"><a href="https://kellblog.com/2019/08/31/if-rebrandings-the-answer-what-was-the-question/" rel="prev"><span class="meta-nav">&larr;</span> If Rebranding’s the Answer, What was the&nbsp;Question?</a></div>
			<div class="nav-next"></div>
		</div><!-- #nav-above -->

		<div id="post-14189" class="post-14189 post type-post status-publish format-standard has-post-thumbnail hentry category-career-development category-halo-effect category-management category-saas category-saastr category-sales category-startups category-uncategorized">

			
			<h1 class="entry-title">Kellblog&#8217;s Greatest Hits 2016-2019 per the Appealie SaaS&nbsp;Awards</h1>
							<div class="entry-meta">
					<span class="meta-prep meta-prep-author">Posted on</span> <a href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" title="8:32 am" rel="bookmark"><span class="entry-date">September 13, 2019</span></a> <span class="comments-link"><span class="meta-sep">|</span> <a href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/#respond">Leave a comment</a></span>
									</div><!-- .entry-meta -->
			
			<div class="entry-content">
				<p>I&#8217;ll be speaking at the APPEALIE 2019 <a href="https://appealie.com/saas-conference/">SaaS Conference and Awards</a> in San Francisco on September 25th and I noticed that in their promotions the folks at APPEALIE had assembled <a href="https://threadreaderapp.com/thread/1172286175438094337.html">their own Kellblog&#8217;s Greatest Hits album</a> from 2016 to 2019, complete with its own cover art.</p>
<p><img data-attachment-id="14191" data-permalink="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/appealie/" data-orig-file="https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg" data-orig-size="697,349" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;Dave Kellogg&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1568329467&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="appealie" data-image-description="" data-medium-file="https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=300" data-large-file="https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=500" class="  wp-image-14191 aligncenter" src="https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=281&#038;h=141" alt="appealie" width="281" height="141" srcset="https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=281&amp;h=141 281w, https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=562&amp;h=282 562w, https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=150&amp;h=75 150w, https://davidkellogg.files.wordpress.com/2019/09/appealie.jpg?w=300&amp;h=150 300w" sizes="(max-width: 281px) 100vw, 281px" /></p>
<p>When I looked at the posts they picked, I thought they did a good job of identifying the best material, so I thought I&#8217;d share their list here.  They also called me &#8220;a GOAT software blogger&#8221; and after playing around with acronyms for about half an hour &#8212; maybe <a href="https://www.groovehq.com/blog">Groove</a>, <a href="https://openviewpartners.com/blog">OpenView</a>, <a href="http://christophjanz.blogspot.co.uk/">AngelVC</a>, <a href="http://tomtunguz.com/">Tunguz</a>? &#8212; my younger son swung by and said, &#8220;they called you a <a href="https://www.urbandictionary.com/define.php?term=goat">GOAT</a>?  Cool.  It means greatest of all time.&#8221;  Cool, indeed.  Thanks.</p>
<p>Here&#8217;s the APPEALIE Kellblog&#8217;s Greatest Hits 2016-2019 list:</p>
<ul>
<li><a href="https://kellblog.com/2019/07/18/career-decisions-what-to-look-for-in-a-software-startup/">Career Decisions:  What to Look For in a Software Startup</a></li>
<li><a href="https://kellblog.com/2019/04/26/reacting-to-feedback-as-ceo/">Reacting to Feedback as CEO</a></li>
<li><a href="https://kellblog.com/2019/01/15/two-natural-reactions-that-great-managers-suppress/">Two Natural Reactions That Great Managers Suppress</a></li>
<li><a href="https://kellblog.com/2018/02/07/my-saastr-2018-presentation-ten-non-obvious-things-about-scaling-saas/">My SaaStr 2018 Presentation:  Ten Non-Obvious Things About Scaling SaaS</a></li>
<li><a href="https://kellblog.com/2018/01/23/quota-over-assignment-and-culture/">Quota Over-Assignment and Culture</a></li>
<li><a href="https://kellblog.com/2018/01/09/eight-words-that-can-limit-your-career-let-me-get-back-to-you-on-that/">Eight Words That Can Limit Your Career (&#8220;Let me get back to you on that.&#8221;)</a></li>
<li><a href="https://kellblog.com/2017/08/14/are-you-a-challenging-or-a-just-plain-difficult-direct-report/">Are You a Challenging or Simply a Difficult Direct Report?</a></li>
<li><a href="https://kellblog.com/2017/07/16/how-to-be-passionate-without-being-a-self-righteous-idiot/">How to be Passionate Without Being Self-Righteous</a></li>
<li><a href="https://kellblog.com/2017/05/07/how-to-get-your-startup-a-halo/">How to Get Your Startup a Halo</a></li>
<li><a href="https://kellblog.com/2017/04/18/do-you-want-to-judged-on-intentions-or-results/">Do You Want to be Judged on Intentions or Results?</a></li>
<li><a href="https://kellblog.com/2017/03/06/10-questions-to-ask-yourself-before-moving-into-management/">Ten Questions to Ask Yourself Before Moving into Management</a></li>
<li><a href="https://kellblog.com/2017/01/12/in-memory-analytics-the-other-kind-and-a-key-success-factor-for-your-career/">In-Memory Analytics:  The Other Kind &#8212; A Key Success Factor for Your Career</a></li>
<li><a href="https://kellblog.com/2016/08/22/the-three-golden-rules-of-feedback/">The Three Golden Rules of Feedback</a></li>
<li><a href="https://kellblog.com/2016/08/19/how-i-got-one-marketing-vp-job-a-quick-lesson/">How I Got One Marketing VP Job:  A Quick Lesson</a></li>
<li><a href="https://kellblog.com/2016/07/19/were-not-buddies-thoughts-on-managers-too-preoccupied-with-being-liked/">We&#8217;re Not Buddies:  Thoughts on Managers Too Preoccupied with Being Liked</a></li>
</ul>
<p>&nbsp;</p>
<div id="jp-post-flair" class="sharedaddy sd-like-enabled sd-sharing-enabled"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-14189" class="share-twitter sd-button share-icon" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/?share=twitter" target="_blank" title="Click to share on Twitter"><span>Twitter</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-14189" class="share-linkedin sd-button share-icon" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span>LinkedIn</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-14189" class="share-facebook sd-button share-icon" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/?share=facebook" target="_blank" title="Click to share on Facebook"><span>Facebook</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-14189" class="share-pinterest sd-button share-icon" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span>Pinterest</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon" href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div><div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-11070789-14189-5d7d66e85883e' data-src='//widgets.wp.com/likes/index.html?ver=20190321#blog_id=11070789&amp;post_id=14189&amp;origin=davidkellogg.wordpress.com&amp;obj_id=11070789-14189-5d7d66e85883e&amp;domain=kellblog.com' data-name='like-post-frame-11070789-14189-5d7d66e85883e'><h3 class='sd-title'>Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div>							</div><!-- .entry-content -->

			<div class="entry-info">
							This entry was posted in <a href="https://kellblog.com/category/career-development/" rel="category tag">Career Development</a>, <a href="https://kellblog.com/category/halo-effect/" rel="category tag">Halo Effect</a>, <a href="https://kellblog.com/category/management/" rel="category tag">Management</a>, <a href="https://kellblog.com/category/saas/" rel="category tag">SaaS</a>, <a href="https://kellblog.com/category/saastr/" rel="category tag">SaaStr</a>, <a href="https://kellblog.com/category/sales/" rel="category tag">Sales</a>, <a href="https://kellblog.com/category/startups/" rel="category tag">Startups</a>, <a href="https://kellblog.com/category/uncategorized/" rel="category tag">Uncategorized</a>. Bookmark the <a href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" title="Permalink to Kellblog&#8217;s Greatest Hits 2016-2019 per the Appealie SaaS&nbsp;Awards" rel="bookmark">permalink</a>.							</div><!-- .entry-info -->
		</div><!-- #post-## -->

		<div id="nav-below" class="navigation">
			<div class="nav-previous"><a href="https://kellblog.com/2019/08/31/if-rebrandings-the-answer-what-was-the-question/" rel="prev"><span class="meta-nav">&larr;</span> If Rebranding’s the Answer, What was the&nbsp;Question?</a></div>
			<div class="nav-next"></div>
		</div><!-- #nav-below -->

		
<div id="comments">

	
	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://kellblog.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<input type="hidden" id="highlander_comment_nonce" name="highlander_comment_nonce" value="7382ed2e79" /><input type="hidden" name="_wp_http_referer" value="/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" />
<input type="hidden" name="hc_post_as" id="hc_post_as" value="guest" />

<div class="comment-form-field comment-textarea">
	<label for="comment">Enter your comment here...</label>
	<div id="comment-form-comment"><textarea id="comment" name="comment" title="Enter your comment here..."></textarea></div>
</div>

<div id="comment-form-identity">
	<div id="comment-form-nascar">
		<p>Fill in your details below or click an icon to log in:</p>
		<ul>
			<li class="selected" style="display:none;">
				<a href="#comment-form-guest" id="postas-guest" class="nascar-signin-link"
                   title="Login via Guest">
									</a>
			</li>
			<li>
				<a href="#comment-form-load-service:WordPress.com" id="postas-wordpress" class="nascar-signin-link"
                   title="Login via WordPress.com">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg>				</a>
			</li>
			<li>
			<li>
				<a href="#comment-form-load-service:Twitter" id="postas-twitter" class="nascar-signin-link"
                   title="Login via Twitter">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg>				</a>
			</li>
			<li>
				<a href="#comment-form-load-service:Facebook" id="postas-facebook" class="nascar-signin-link"
                   title="Login via Facebook">
					<svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg>				</a>
			</li>
		</ul>
	</div>

	<div id="comment-form-guest" class="comment-form-service selected">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
<a href="https://gravatar.com/site/signup/" target="_blank">				<img src="" alt="Gravatar" width="25" class="no-grav" />
</a>			</div>

				<div class="comment-form-fields">
				<div class="comment-form-field comment-form-email">
					<label for="email">Email <span class="required">(required)</span> <span class="nopublish">(Address never made public)</span></label>
					<div class="comment-form-input"><input id="email" name="email" type="email" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-author">
					<label for="author">Name <span class="required">(required)</span></label>
					<div class="comment-form-input"><input id="author" name="author" type="text" value="" /></div>
				</div>
				<div class="comment-form-field comment-form-url">
					<label for="url">Website</label>
					<div class="comment-form-input"><input id="url" name="url" type="url" value="" /></div>
				</div>
			</div>
			
		</div>
	</div>

	<div id="comment-form-wordpress" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="WordPress.com Logo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="wp_avatar" id="wordpress-avatar" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_user_id" id="wordpress-user_id" class="comment-meta-wordpress" value="" />
				<input type="hidden" name="wp_access_token" id="wordpress-access_token" class="comment-meta-wordpress" value="" />
						<p class="comment-form-posting-as pa-wordpress">
			<strong></strong>
			You are commenting using your WordPress.com account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'wordpress' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#0087be" d="M12.158 12.786l-2.698 7.84c.806.236 1.657.365 2.54.365 1.047 0 2.05-.18 2.986-.51-.024-.037-.046-.078-.065-.123l-2.762-7.57zM3.008 12c0 3.56 2.07 6.634 5.068 8.092L3.788 8.342c-.5 1.117-.78 2.354-.78 3.658zm15.06-.454c0-1.112-.398-1.88-.74-2.48-.456-.74-.883-1.368-.883-2.11 0-.825.627-1.595 1.51-1.595.04 0 .078.006.116.008-1.598-1.464-3.73-2.36-6.07-2.36-3.14 0-5.904 1.613-7.512 4.053.21.008.41.012.58.012.94 0 2.395-.114 2.395-.114.484-.028.54.684.057.74 0 0-.487.058-1.03.086l3.275 9.74 1.968-5.902-1.4-3.838c-.485-.028-.944-.085-.944-.085-.486-.03-.43-.77.056-.742 0 0 1.484.114 2.368.114.94 0 2.397-.114 2.397-.114.486-.028.543.684.058.74 0 0-.488.058-1.03.086l3.25 9.665.897-2.997c.456-1.17.684-2.137.684-2.907zm1.82-3.86c.04.286.06.593.06.924 0 .912-.17 1.938-.683 3.22l-2.746 7.94c2.672-1.558 4.47-4.454 4.47-7.77 0-1.564-.4-3.033-1.1-4.314zM12 22C6.486 22 2 17.514 2 12S6.486 2 12 2s10 4.486 10 10-4.486 10-10 10z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-googleplus" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Google photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="googleplus_avatar" id="googleplus-avatar" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_user_id" id="googleplus-user_id" class="comment-meta-googleplus" value="" />
				<input type="hidden" name="googleplus_access_token" id="googleplus-access_token" class="comment-meta-googleplus" value="" />
						<p class="comment-form-posting-as pa-googleplus">
			<strong></strong>
			You are commenting using your Google account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'googleplus' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" x="0px" y="0px" viewBox="0 0 60 60" ><path fill="#519bf7" d="M56.3,30c0,-1.6 -0.2,-3.4 -0.6,-5h-3.1H42.2H30v10.6h14.8C44,39.3 42,42 39.1,43.9l8.8,6.8C53,46 56.3,39 56.3,30z" /><path fill="#3db366" d="M30,57.5c6.7,0 13.1,-2.4 17.9,-6.8l-8.8,-6.8c-2.5,1.6 -5.6,2.4 -9.1,2.4c-7.2,0 -13.3,-4.7 -15.4,-11.2l-9.3,7.1C9.8,51.3 19.1,57.5 30,57.5z" /><path fill="#fdc600" d="M5.3,42.2l9.3,-7.1c-0.5,-1.6 -0.8,-3.3 -0.8,-5.1s0.3,-3.5 0.8,-5.1l-9.3,-7.1C3.5,21.5 2.5,25.6 2.5,30S3.5,38.5 5.3,42.2z" /><path fill="#f15b44" d="M40.1,17.4l8,-8C43.3,5.1 37,2.5 30,2.5C19.1,2.5 9.8,8.7 5.3,17.8l9.3,7.1c2.1,-6.5 8.2,-11.1 15.4,-11.1C33.9,13.7 37.4,15.1 40.1,17.4z" /></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-twitter" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Twitter picture" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="twitter_avatar" id="twitter-avatar" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_user_id" id="twitter-user_id" class="comment-meta-twitter" value="" />
				<input type="hidden" name="twitter_access_token" id="twitter-access_token" class="comment-meta-twitter" value="" />
						<p class="comment-form-posting-as pa-twitter">
			<strong></strong>
			You are commenting using your Twitter account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'twitter' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#1DA1F2" d="M22.23 5.924c-.736.326-1.527.547-2.357.646.847-.508 1.498-1.312 1.804-2.27-.793.47-1.67.812-2.606.996C18.325 4.498 17.258 4 16.078 4c-2.266 0-4.103 1.837-4.103 4.103 0 .322.036.635.106.935-3.41-.17-6.433-1.804-8.457-4.287-.353.607-.556 1.312-.556 2.064 0 1.424.724 2.68 1.825 3.415-.673-.022-1.305-.207-1.86-.514v.052c0 1.988 1.415 3.647 3.293 4.023-.344.095-.707.145-1.08.145-.265 0-.522-.026-.773-.074.522 1.63 2.038 2.817 3.833 2.85-1.404 1.1-3.174 1.757-5.096 1.757-.332 0-.66-.02-.98-.057 1.816 1.164 3.973 1.843 6.29 1.843 7.547 0 11.675-6.252 11.675-11.675 0-.178-.004-.355-.012-.53.802-.578 1.497-1.3 2.047-2.124z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>

	<div id="comment-form-facebook" class="comment-form-service">
		<div class="comment-form-padder">
			<div class="comment-form-avatar">
				<img src="" alt="Facebook photo" width="25" class="no-grav" />
			</div>

				<div class="comment-form-fields">
				<input type="hidden" name="fb_avatar" id="facebook-avatar" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_user_id" id="facebook-user_id" class="comment-meta-facebook" value="" />
				<input type="hidden" name="fb_access_token" id="facebook-access_token" class="comment-meta-facebook" value="" />
						<p class="comment-form-posting-as pa-facebook">
			<strong></strong>
			You are commenting using your Facebook account.			<span class="comment-form-log-out">
				(&nbsp;<a href="javascript:HighlanderComments.doExternalLogout( 'facebook' );">Log&nbsp;Out</a>&nbsp;/&nbsp;
				<a href="#" onclick="javascript:HighlanderComments.switchAccount();return false;">Change</a>&nbsp;)
			</span>
			<span class="pa-icon"><svg xmlns="http://www.w3.org/2000/svg" role="presentation" viewBox="0 0 24 24" ><rect x="0" fill="none" width="24" height="24"/><g><path fill="#3B5998" d="M20.007 3H3.993C3.445 3 3 3.445 3 3.993v16.013c0 .55.445.994.993.994h8.62v-6.97H10.27V11.31h2.346V9.31c0-2.325 1.42-3.59 3.494-3.59.993 0 1.847.073 2.096.106v2.43h-1.438c-1.128 0-1.346.537-1.346 1.324v1.734h2.69l-.35 2.717h-2.34V21h4.587c.548 0 .993-.445.993-.993V3.993c0-.548-.445-.993-.993-.993z"/></g></svg></span>
		</p>
					</div>
	
		</div>
	</div>


	<div id="comment-form-load-service" class="comment-form-service">
		<div class="comment-form-posting-as-cancel"><a href="javascript:HighlanderComments.cancelExternalWindow();">Cancel</a></div>
		<p>Connecting to %s</p>
	</div>

</div>

<script type="text/javascript">
var highlander_expando_javascript = function(){
	var input = document.createElement( 'input' ),
	    comment = jQuery( '#comment' );

	if ( 'placeholder' in input ) {
		comment.attr( 'placeholder', jQuery( '.comment-textarea label' ).remove().text() );
	}

	// Expando Mode: start small, then auto-resize on first click + text length
	jQuery( '#comment-form-identity' ).hide();
	jQuery( '#comment-form-subscribe' ).hide();
	jQuery( '#commentform .form-submit' ).hide();

	comment.css( { 'height':'10px' } ).one( 'focus', function() {
		var timer = setInterval( HighlanderComments.resizeCallback, 10 )
		jQuery( this ).animate( { 'height': HighlanderComments.initialHeight } ).delay( 100 ).queue( function(n) { clearInterval( timer ); HighlanderComments.resizeCallback(); n(); } );
		jQuery( '#comment-form-identity' ).slideDown();
		jQuery( '#comment-form-subscribe' ).slideDown();
		jQuery( '#commentform .form-submit' ).slideDown();
	});
}
jQuery(document).ready( highlander_expando_javascript );
</script>

<div id="comment-form-subscribe">
	<p class="comment-subscription-form"><input type="checkbox" name="subscribe" id="subscribe" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-label" for="subscribe" style="display: inline;">Notify me of new comments via email.</label></p><p class="post-subscription-form"><input type="checkbox" name="subscribe_blog" id="subscribe_blog" value="subscribe" style="width: auto;"/> <label class="subscribe-label" id="subscribe-blog-label" for="subscribe_blog"  style="display: inline;">Notify me of new posts via email.</label></p></div>

<style type="text/css">
#respond .comment-form-avatar { display: none !important; }
#respond .comment-form-fields { margin-left: 0 !important; }
#respond .comment-form-cookies-consent { margin-left: 0 !important; }
</style>




<p class="form-submit"><input name="submit" type="submit" id="comment-submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='14189' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="0733cab8a3" /></p>
<input type="hidden" name="genseq" value="1568499432" />
<p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="249"/></p>			</form>
			</div><!-- #respond -->
	<div style="clear: both"></div>
</div><!-- #comments -->
	
	</div><!-- #content -->
</div><!-- #content-container -->


		
		<div id="primary" class="widget-area" role="complementary">
					<ul class="xoxo">

			<li id="text-3" class="widget-container widget_text">			<div class="textwidget"><div id="bio">
<p><img class=" wp-image-13320 alignleft" src="https://davidkellogg.files.wordpress.com/2018/01/dk-headshot-bio-untouched-keffer-1-slate.png?w=500" alt="" width="105" height="84" /></p>
<p>I&#8217;m Dave Kellogg, technology executive, angel investor, independent director, advisor, and blogger.  I bring a balanced and somewhat rare perspective to software company challeges &#8212;  bringing 10+ years&#8217; experience at each of the CMO, CEO, and board levels across across ten different enterprise software companies, ranging in size from $0M to over $1B in revenues.</p>
<p>In 2019, I was honored to be named a <a href="https://www.saastr.com/saastrs-most-respected-leaders-awards-2019-the-top-five/">Top 5 Leader in SaaS</a> per the 15,000 attendees at SaaStr.</p>
<p>From 2012 to 2018, I was CEO of cloud enterprise performance management vendor Host Analytics, where we quintupled ARR while halving customer acquisition costs in a highly competitive market, ultimately selling the company in a private equity transaction.</p>
<p>Previously, I was SVP/GM of the $500M Service Cloud business at Salesforce, CEO at NoSQL database provider MarkLogic where we grew the company from zero to $80M in run-rate revenues over a six-year period, and CMO at Business Objects for nearly a decade as we grew from $30M to over $1B in revenues. I started my career in technical and product marketing positions at Ingres and Versant.</p>
<p>I love disruption, startups, and Silicon Valley and have had the pleasure of working in varied capacities with companies including ClearedIn, FloQast, GainSight, Kelda, Lecida, MongoDB, Plannuh, Recorded Future, Tableau and TopOPPs.</p>
<p>I currently sit on the boards of <a href="https://alation.com">Alation</a> (data catalogs), <a href="https://www.nuxeo.com">Nuxeo</a> (content management), and <a href="https://www.profisee.com">Profisee</a> (master data management).  I previously sat on the boards of agtech leader Granular (acquired by DuPont for $300M) and big data leader Aster Data (acquired by Teradata for $325M).</p>
<p>I periodically speak to strategy and entrepreneurship classes at the Haas School of Business (UC Berkeley) and Hautes Études Commerciales de Paris (HEC).</p>
<p><a href="/frequently-asked-questions/">Read Frequently Asked Questions.</a><br />
<a href="mailto:davekellogg@mail.com">Contact Dave.</a></p>
</div>
</div>
		</li><li id="text-8" class="widget-container widget_text"><h3 class="widget-title">Updates</h3>			<div class="textwidget"><div id="updates">
<a id="link_twitter" href="http://twitter.com/kellblog">Twitter</a>
<a id="link_email" href="http://feedburner.google.com/fb/a/mailverify?uri=blogspot/FLvP" target="_blank" rel="noopener noreferrer">Email</a>
<a id="link_rss" href="http://feeds.feedburner.com/kellblog">RSS</a>
</div></div>
		</li><li id="blog_subscription-3" class="widget-container widget_blog_subscription jetpack_subscription_widget"><h3 class="widget-title"><label for="subscribe-field">Follow Blog via Email</label></h3>
            <form action="https://subscribe.wordpress.com" method="post" accept-charset="utf-8"
                  id="subscribe-blog">
									<p>Enter your email address to follow this blog and receive notifications of new posts by email.</p>
                    <p><input type="text" name="email" style="width: 95%; padding: 1px 2px"
                              placeholder="Enter your email address" value=""
                              id="subscribe-field"/></p>
				
                <p>
                    <input type="hidden" name="action" value="subscribe"/>
                    <input type="hidden" name="blog_id" value="11070789"/>
                    <input type="hidden" name="source" value="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/"/>
                    <input type="hidden" name="sub-type" value="widget"/>
                    <input type="hidden" name="redirect_fragment" value="blog_subscription-3"/>
					<input type="hidden" id="_wpnonce" name="_wpnonce" value="5c4b4bafb3" />                    <button type="submit"
	                    		                	                >
	                    Follow                    </button>
                </p>
            </form>
			
</li><li id="top-posts-2" class="widget-container widget_top-posts"><h3 class="widget-title">Popular Posts</h3><ul>				<li>
										<a href="https://kellblog.com/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" class="bump-view" data-bump-view="tp">
						Kellblog&#039;s Greatest Hits 2016-2019 per the Appealie SaaS Awards					</a>
										</li>
								<li>
										<a href="https://kellblog.com/2019/01/19/an-update-on-the-saas-rule-of-40/" class="bump-view" data-bump-view="tp">
						An Update on the SaaS Rule of 40					</a>
										</li>
								<li>
										<a href="https://kellblog.com/2015/03/08/career-development-what-it-really-means-to-be-a-manager-director-or-vp/" class="bump-view" data-bump-view="tp">
						Career Development:  What It Really Means to be a Manager, Director, or VP					</a>
										</li>
								<li>
										<a href="https://kellblog.com/2018/01/09/eight-words-that-can-limit-your-career-let-me-get-back-to-you-on-that/" class="bump-view" data-bump-view="tp">
						Eight Words that Can Limit Your Career:  &quot;Let Me Get Back To You On That&quot;					</a>
										</li>
								<li>
										<a href="https://kellblog.com/2019/01/15/two-natural-reactions-that-great-managers-suppress/" class="bump-view" data-bump-view="tp">
						Two Natural Reactions That Great Managers Suppress					</a>
										</li>
				</ul></li><li id="text-9" class="widget-container widget_text"><h3 class="widget-title">Best of Kellblog</h3>			<div class="textwidget"><a href="http://www.kellblog.com/best-of-kellblog/">Read My Top Favorite Posts</a></div>
		</li><li id="twitter_timeline-2" class="widget-container widget_twitter_timeline"><h3 class="widget-title">Recent Tweets</h3><a class="twitter-timeline" data-theme="light" data-link-color="#f96e5b" data-border-color="#e8e8e8" data-tweet-limit="3" data-lang="EN" data-partner="jetpack" data-chrome="noheader nofooter" href="https://twitter.com/kellblog" href="https://twitter.com/kellblog">My Tweets</a></li><li id="categories-4" class="widget-container widget_categories"><h3 class="widget-title">Categories</h3><form action="https://kellblog.com" method="get"><label class="screen-reader-text" for="cat">Categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="222591380">Adaptive Insights</option>
	<option class="level-0" value="521">Advertising</option>
	<option class="level-0" value="11287">Agile</option>
	<option class="level-0" value="21446220">AgTech</option>
	<option class="level-0" value="10544">Analysis</option>
	<option class="level-0" value="139620">Analyst Relations</option>
	<option class="level-0" value="11453">Analytics</option>
	<option class="level-0" value="75685968">Anaplan</option>
	<option class="level-0" value="6758">Awards</option>
	<option class="level-0" value="19316">BI</option>
	<option class="level-0" value="2075170">Big Data</option>
	<option class="level-0" value="91">Blogging</option>
	<option class="level-0" value="79128">Board</option>
	<option class="level-0" value="210822">Bookings</option>
	<option class="level-0" value="8260">Branding</option>
	<option class="level-0" value="45854">Bubble</option>
	<option class="level-0" value="36951">Budgeting</option>
	<option class="level-0" value="117765">Business Objects</option>
	<option class="level-0" value="616575">CAC</option>
	<option class="level-0" value="219993">Capacity</option>
	<option class="level-0" value="20720">Career Development</option>
	<option class="level-0" value="10406">CEO</option>
	<option class="level-0" value="53067">CFO</option>
	<option class="level-0" value="14526">change</option>
	<option class="level-0" value="160581095">Chasm Crossing</option>
	<option class="level-0" value="104802">churn</option>
	<option class="level-0" value="131782">Close</option>
	<option class="level-0" value="244496992">Close Management</option>
	<option class="level-0" value="69816">Cloud</option>
	<option class="level-0" value="7742">Communications</option>
	<option class="level-0" value="2528">Community</option>
	<option class="level-0" value="472">Competition</option>
	<option class="level-0" value="19674">Consolidation</option>
	<option class="level-0" value="590014">Consolidations</option>
	<option class="level-0" value="113">Content</option>
	<option class="level-0" value="195029">CPM</option>
	<option class="level-0" value="4259">CRM</option>
	<option class="level-0" value="1210871">CSAT</option>
	<option class="level-0" value="459406">CSM</option>
	<option class="level-0" value="1098">Culture</option>
	<option class="level-0" value="655919">customer success</option>
	<option class="level-0" value="7344">CX</option>
	<option class="level-0" value="9258636">CXM</option>
	<option class="level-0" value="867">Data Mining</option>
	<option class="level-0" value="21818323">Data Science</option>
	<option class="level-0" value="475">Database</option>
	<option class="level-0" value="67837">Decision Making</option>
	<option class="level-0" value="34765869">demandgen</option>
	<option class="level-0" value="148">Design</option>
	<option class="level-0" value="4619">Disruption</option>
	<option class="level-0" value="143933">Documentum</option>
	<option class="level-0" value="138102">ECM</option>
	<option class="level-0" value="650430">Endeca</option>
	<option class="level-0" value="400734">Enterprise Search</option>
	<option class="level-0" value="99155">Enterprise Software</option>
	<option class="level-0" value="183">Entrepreneurship</option>
	<option class="level-0" value="662352">EPM</option>
	<option class="level-0" value="924">Events</option>
	<option class="level-0" value="19313">Excel Hell</option>
	<option class="level-0" value="81819">Facebook</option>
	<option class="level-0" value="3233415">Fast Search</option>
	<option class="level-0" value="70681794">FCPM</option>
	<option class="level-0" value="4269">Finance</option>
	<option class="level-0" value="31435685">Finance Transformation</option>
	<option class="level-0" value="7489">Financial</option>
	<option class="level-0" value="40407">Financing</option>
	<option class="level-0" value="581590">forecasting</option>
	<option class="level-0" value="691215">FPA</option>
	<option class="level-0" value="4704">France</option>
	<option class="level-0" value="328920">Gartner</option>
	<option class="level-0" value="1743461">GEI</option>
	<option class="level-0" value="81">Google</option>
	<option class="level-0" value="75701">Grateful Dead</option>
	<option class="level-0" value="3251196">Hadoop</option>
	<option class="level-0" value="1679029">Halo Effect</option>
	<option class="level-0" value="113932">Hiring</option>
	<option class="level-0" value="27875893">Host Analytics</option>
	<option class="level-0" value="22518">HP</option>
	<option class="level-0" value="39956">HR</option>
	<option class="level-0" value="32744">IBM</option>
	<option class="level-0" value="105388">In-Memory</option>
	<option class="level-0" value="3054">India</option>
	<option class="level-0" value="186">Innovation</option>
	<option class="level-0" value="1310359">Innovator&#8217;s Dilemma</option>
	<option class="level-0" value="310880">Innumeracy</option>
	<option class="level-0" value="14066">Intelligence</option>
	<option class="level-0" value="18477">IPO</option>
	<option class="level-0" value="7885">Leadership</option>
	<option class="level-0" value="2890144">LTV</option>
	<option class="level-0" value="18960">M&amp;A</option>
	<option class="level-0" value="2151166">Magic Quadrant</option>
	<option class="level-0" value="4236">Management</option>
	<option class="level-0" value="7138">Market Research</option>
	<option class="level-0" value="175">Marketing</option>
	<option class="level-0" value="4232101">MarkLogic</option>
	<option class="level-0" value="456787">Master Data Management</option>
	<option class="level-0" value="292">Media</option>
	<option class="level-0" value="7092">Metrics</option>
	<option class="level-0" value="637">Microsoft</option>
	<option class="level-0" value="258395">MicroStrategy</option>
	<option class="level-0" value="19878">Modeling</option>
	<option class="level-0" value="472999">Moore&#8217;s Law</option>
	<option class="level-0" value="3747">Newspaper</option>
	<option class="level-0" value="22319505">NoSQL</option>
	<option class="level-0" value="5224487">OKR</option>
	<option class="level-0" value="296013">onboarding</option>
	<option class="level-0" value="25">Open Source</option>
	<option class="level-0" value="3766">Oracle</option>
	<option class="level-0" value="31678">Organizational Behavior</option>
	<option class="level-0" value="811609">OSINT</option>
	<option class="level-0" value="3812524">Palantir</option>
	<option class="level-0" value="34463">Pipeline</option>
	<option class="level-0" value="4599">Planning</option>
	<option class="level-0" value="90941">Positioning</option>
	<option class="level-0" value="635">PR</option>
	<option class="level-0" value="22707">Predictions</option>
	<option class="level-0" value="51999">Pricing</option>
	<option class="level-0" value="3279">Privacy</option>
	<option class="level-0" value="29172">Private Equity</option>
	<option class="level-0" value="9719">process</option>
	<option class="level-0" value="30787">Product Management</option>
	<option class="level-0" value="50025">Product Strategy</option>
	<option class="level-0" value="559536">Professional Services</option>
	<option class="level-0" value="15873877">QCR</option>
	<option class="level-0" value="1568">Randomness</option>
	<option class="level-0" value="282303">RDBMS</option>
	<option class="level-0" value="8452">Recruiting</option>
	<option class="level-0" value="197">Relationships</option>
	<option class="level-0" value="87780">Retention</option>
	<option class="level-0" value="749757">RRE</option>
	<option class="level-0" value="74526919">Rule of 40</option>
	<option class="level-0" value="17927">SaaS</option>
	<option class="level-0" value="142075190">SaaStr</option>
	<option class="level-0" value="7094">Sales</option>
	<option class="level-0" value="5909422">sales model</option>
	<option class="level-0" value="251875074">salesops</option>
	<option class="level-0" value="1084675">SAP AG</option>
	<option class="level-0" value="320209">Scaling</option>
	<option class="level-0" value="42308177">SCPM</option>
	<option class="level-0" value="2373">Search</option>
	<option class="level-0" value="5655">Semantic</option>
	<option class="level-0" value="479814">Sequoia</option>
	<option class="level-0" value="6582790">Shoshin</option>
	<option class="level-0" value="49875">Silicon Valley</option>
	<option class="level-0" value="3457">Social</option>
	<option class="level-0" value="1652">social networking</option>
	<option class="level-0" value="26658">Solutions</option>
	<option class="level-0" value="22397">Spreadsheets</option>
	<option class="level-0" value="20429">Startups</option>
	<option class="level-0" value="14543346">Stonebraker</option>
	<option class="level-0" value="8553">Strategy</option>
	<option class="level-0" value="429">Sun</option>
	<option class="level-0" value="1092">Surveys</option>
	<option class="level-0" value="852300">Tableau</option>
	<option class="level-0" value="16931">TechCrunch</option>
	<option class="level-0" value="38262249">Technology laws</option>
	<option class="level-0" value="621903">Terms of Service</option>
	<option class="level-0" value="2495437">text analytics</option>
	<option class="level-0" value="30057625">thick middle tier</option>
	<option class="level-0" value="57610">Trust</option>
	<option class="level-0" value="599182">Twitter</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="39336813">Unicorn</option>
	<option class="level-0" value="27882118">Unit Economics</option>
	<option class="level-0" value="2789202">Unstructured</option>
	<option class="level-0" value="2476923">upsell</option>
	<option class="level-0" value="37820">Valuation</option>
	<option class="level-0" value="202">Venture Capital</option>
	<option class="level-0" value="3161794">Web 2.0</option>
	<option class="level-0" value="11601">Wisdom of Crowds</option>
	<option class="level-0" value="6852">XML</option>
	<option class="level-0" value="36973">XQuery</option>
</select>
</form>
<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</li><li id="search-3" class="widget-container widget_search"><h3 class="widget-title">Search Kellblog</h3><form role="search" method="get" id="searchform" class="searchform" action="https://kellblog.com/">
				<div>
					<label class="screen-reader-text" for="s">Search for:</label>
					<input type="text" value="" name="s" id="s" />
					<input type="submit" id="searchsubmit" value="Search" />
				</div>
			</form></li><li id="archives-3" class="widget-container widget_archive"><h3 class="widget-title">Archives</h3>		<label class="screen-reader-text" for="archives-dropdown-3">Archives</label>
		<select id="archives-dropdown-3" name="archive-dropdown">
			
			<option value="">Select Month</option>
				<option value='https://kellblog.com/2019/09/'> September 2019 </option>
	<option value='https://kellblog.com/2019/08/'> August 2019 </option>
	<option value='https://kellblog.com/2019/07/'> July 2019 </option>
	<option value='https://kellblog.com/2019/06/'> June 2019 </option>
	<option value='https://kellblog.com/2019/05/'> May 2019 </option>
	<option value='https://kellblog.com/2019/04/'> April 2019 </option>
	<option value='https://kellblog.com/2019/03/'> March 2019 </option>
	<option value='https://kellblog.com/2019/02/'> February 2019 </option>
	<option value='https://kellblog.com/2019/01/'> January 2019 </option>
	<option value='https://kellblog.com/2018/12/'> December 2018 </option>
	<option value='https://kellblog.com/2018/11/'> November 2018 </option>
	<option value='https://kellblog.com/2018/10/'> October 2018 </option>
	<option value='https://kellblog.com/2018/09/'> September 2018 </option>
	<option value='https://kellblog.com/2018/08/'> August 2018 </option>
	<option value='https://kellblog.com/2018/07/'> July 2018 </option>
	<option value='https://kellblog.com/2018/06/'> June 2018 </option>
	<option value='https://kellblog.com/2018/05/'> May 2018 </option>
	<option value='https://kellblog.com/2018/04/'> April 2018 </option>
	<option value='https://kellblog.com/2018/03/'> March 2018 </option>
	<option value='https://kellblog.com/2018/02/'> February 2018 </option>
	<option value='https://kellblog.com/2018/01/'> January 2018 </option>
	<option value='https://kellblog.com/2017/11/'> November 2017 </option>
	<option value='https://kellblog.com/2017/10/'> October 2017 </option>
	<option value='https://kellblog.com/2017/09/'> September 2017 </option>
	<option value='https://kellblog.com/2017/08/'> August 2017 </option>
	<option value='https://kellblog.com/2017/07/'> July 2017 </option>
	<option value='https://kellblog.com/2017/06/'> June 2017 </option>
	<option value='https://kellblog.com/2017/05/'> May 2017 </option>
	<option value='https://kellblog.com/2017/04/'> April 2017 </option>
	<option value='https://kellblog.com/2017/03/'> March 2017 </option>
	<option value='https://kellblog.com/2017/02/'> February 2017 </option>
	<option value='https://kellblog.com/2017/01/'> January 2017 </option>
	<option value='https://kellblog.com/2016/12/'> December 2016 </option>
	<option value='https://kellblog.com/2016/11/'> November 2016 </option>
	<option value='https://kellblog.com/2016/10/'> October 2016 </option>
	<option value='https://kellblog.com/2016/09/'> September 2016 </option>
	<option value='https://kellblog.com/2016/08/'> August 2016 </option>
	<option value='https://kellblog.com/2016/07/'> July 2016 </option>
	<option value='https://kellblog.com/2016/06/'> June 2016 </option>
	<option value='https://kellblog.com/2016/05/'> May 2016 </option>
	<option value='https://kellblog.com/2016/04/'> April 2016 </option>
	<option value='https://kellblog.com/2016/03/'> March 2016 </option>
	<option value='https://kellblog.com/2016/02/'> February 2016 </option>
	<option value='https://kellblog.com/2016/01/'> January 2016 </option>
	<option value='https://kellblog.com/2015/12/'> December 2015 </option>
	<option value='https://kellblog.com/2015/11/'> November 2015 </option>
	<option value='https://kellblog.com/2015/10/'> October 2015 </option>
	<option value='https://kellblog.com/2015/09/'> September 2015 </option>
	<option value='https://kellblog.com/2015/08/'> August 2015 </option>
	<option value='https://kellblog.com/2015/07/'> July 2015 </option>
	<option value='https://kellblog.com/2015/06/'> June 2015 </option>
	<option value='https://kellblog.com/2015/05/'> May 2015 </option>
	<option value='https://kellblog.com/2015/04/'> April 2015 </option>
	<option value='https://kellblog.com/2015/03/'> March 2015 </option>
	<option value='https://kellblog.com/2015/02/'> February 2015 </option>
	<option value='https://kellblog.com/2015/01/'> January 2015 </option>
	<option value='https://kellblog.com/2014/12/'> December 2014 </option>
	<option value='https://kellblog.com/2014/11/'> November 2014 </option>
	<option value='https://kellblog.com/2014/10/'> October 2014 </option>
	<option value='https://kellblog.com/2014/09/'> September 2014 </option>
	<option value='https://kellblog.com/2014/08/'> August 2014 </option>
	<option value='https://kellblog.com/2014/07/'> July 2014 </option>
	<option value='https://kellblog.com/2014/06/'> June 2014 </option>
	<option value='https://kellblog.com/2014/05/'> May 2014 </option>
	<option value='https://kellblog.com/2014/04/'> April 2014 </option>
	<option value='https://kellblog.com/2014/03/'> March 2014 </option>
	<option value='https://kellblog.com/2014/02/'> February 2014 </option>
	<option value='https://kellblog.com/2014/01/'> January 2014 </option>
	<option value='https://kellblog.com/2013/12/'> December 2013 </option>
	<option value='https://kellblog.com/2013/11/'> November 2013 </option>
	<option value='https://kellblog.com/2013/10/'> October 2013 </option>
	<option value='https://kellblog.com/2013/09/'> September 2013 </option>
	<option value='https://kellblog.com/2013/08/'> August 2013 </option>
	<option value='https://kellblog.com/2013/07/'> July 2013 </option>
	<option value='https://kellblog.com/2013/06/'> June 2013 </option>
	<option value='https://kellblog.com/2013/05/'> May 2013 </option>
	<option value='https://kellblog.com/2013/04/'> April 2013 </option>
	<option value='https://kellblog.com/2012/03/'> March 2012 </option>
	<option value='https://kellblog.com/2012/02/'> February 2012 </option>
	<option value='https://kellblog.com/2012/01/'> January 2012 </option>
	<option value='https://kellblog.com/2011/12/'> December 2011 </option>
	<option value='https://kellblog.com/2011/11/'> November 2011 </option>
	<option value='https://kellblog.com/2011/10/'> October 2011 </option>
	<option value='https://kellblog.com/2011/09/'> September 2011 </option>
	<option value='https://kellblog.com/2011/08/'> August 2011 </option>
	<option value='https://kellblog.com/2011/07/'> July 2011 </option>
	<option value='https://kellblog.com/2011/06/'> June 2011 </option>
	<option value='https://kellblog.com/2011/05/'> May 2011 </option>
	<option value='https://kellblog.com/2011/04/'> April 2011 </option>
	<option value='https://kellblog.com/2011/03/'> March 2011 </option>
	<option value='https://kellblog.com/2011/02/'> February 2011 </option>
	<option value='https://kellblog.com/2011/01/'> January 2011 </option>
	<option value='https://kellblog.com/2010/12/'> December 2010 </option>
	<option value='https://kellblog.com/2010/11/'> November 2010 </option>
	<option value='https://kellblog.com/2010/10/'> October 2010 </option>
	<option value='https://kellblog.com/2010/09/'> September 2010 </option>
	<option value='https://kellblog.com/2010/08/'> August 2010 </option>
	<option value='https://kellblog.com/2010/07/'> July 2010 </option>
	<option value='https://kellblog.com/2010/06/'> June 2010 </option>
	<option value='https://kellblog.com/2010/05/'> May 2010 </option>
	<option value='https://kellblog.com/2010/04/'> April 2010 </option>
	<option value='https://kellblog.com/2010/03/'> March 2010 </option>
	<option value='https://kellblog.com/2010/02/'> February 2010 </option>
	<option value='https://kellblog.com/2010/01/'> January 2010 </option>
	<option value='https://kellblog.com/2009/12/'> December 2009 </option>
	<option value='https://kellblog.com/2009/11/'> November 2009 </option>
	<option value='https://kellblog.com/2009/10/'> October 2009 </option>
	<option value='https://kellblog.com/2009/09/'> September 2009 </option>
	<option value='https://kellblog.com/2009/08/'> August 2009 </option>
	<option value='https://kellblog.com/2009/07/'> July 2009 </option>
	<option value='https://kellblog.com/2009/06/'> June 2009 </option>
	<option value='https://kellblog.com/2009/05/'> May 2009 </option>
	<option value='https://kellblog.com/2009/04/'> April 2009 </option>
	<option value='https://kellblog.com/2009/03/'> March 2009 </option>
	<option value='https://kellblog.com/2009/02/'> February 2009 </option>
	<option value='https://kellblog.com/2009/01/'> January 2009 </option>
	<option value='https://kellblog.com/2008/12/'> December 2008 </option>
	<option value='https://kellblog.com/2008/11/'> November 2008 </option>
	<option value='https://kellblog.com/2008/10/'> October 2008 </option>
	<option value='https://kellblog.com/2008/09/'> September 2008 </option>
	<option value='https://kellblog.com/2008/08/'> August 2008 </option>
	<option value='https://kellblog.com/2008/07/'> July 2008 </option>
	<option value='https://kellblog.com/2008/06/'> June 2008 </option>
	<option value='https://kellblog.com/2008/05/'> May 2008 </option>
	<option value='https://kellblog.com/2008/04/'> April 2008 </option>
	<option value='https://kellblog.com/2008/03/'> March 2008 </option>
	<option value='https://kellblog.com/2008/02/'> February 2008 </option>
	<option value='https://kellblog.com/2008/01/'> January 2008 </option>
	<option value='https://kellblog.com/2007/12/'> December 2007 </option>
	<option value='https://kellblog.com/2007/11/'> November 2007 </option>
	<option value='https://kellblog.com/2007/10/'> October 2007 </option>
	<option value='https://kellblog.com/2007/09/'> September 2007 </option>
	<option value='https://kellblog.com/2007/08/'> August 2007 </option>
	<option value='https://kellblog.com/2007/07/'> July 2007 </option>
	<option value='https://kellblog.com/2007/06/'> June 2007 </option>
	<option value='https://kellblog.com/2007/05/'> May 2007 </option>
	<option value='https://kellblog.com/2007/04/'> April 2007 </option>
	<option value='https://kellblog.com/2007/03/'> March 2007 </option>
	<option value='https://kellblog.com/2007/02/'> February 2007 </option>
	<option value='https://kellblog.com/2007/01/'> January 2007 </option>
	<option value='https://kellblog.com/2006/12/'> December 2006 </option>
	<option value='https://kellblog.com/2006/11/'> November 2006 </option>
	<option value='https://kellblog.com/2006/10/'> October 2006 </option>
	<option value='https://kellblog.com/2006/09/'> September 2006 </option>
	<option value='https://kellblog.com/2006/08/'> August 2006 </option>
	<option value='https://kellblog.com/2006/07/'> July 2006 </option>
	<option value='https://kellblog.com/2006/06/'> June 2006 </option>
	<option value='https://kellblog.com/2006/05/'> May 2006 </option>
	<option value='https://kellblog.com/2006/04/'> April 2006 </option>
	<option value='https://kellblog.com/2006/03/'> March 2006 </option>
	<option value='https://kellblog.com/2005/12/'> December 2005 </option>
	<option value='https://kellblog.com/2005/11/'> November 2005 </option>
	<option value='https://kellblog.com/2005/10/'> October 2005 </option>
	<option value='https://kellblog.com/2005/09/'> September 2005 </option>
	<option value='https://kellblog.com/2005/08/'> August 2005 </option>

		</select>

<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "archives-dropdown-3" );
	function onSelectChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value !== '' ) {
			document.location.href = this.options[ this.selectedIndex ].value;
		}
	}
	dropdown.onchange = onSelectChange;
})();
/* ]]> */
</script>

		</li><li id="text-10" class="widget-container widget_text">			<div class="textwidget"><div id="blogDescription">
Kellblog covers topics related to starting, managing, leading, and scaling enterprise software startups.  My favorite topics include strategy, marketing, sales, SaaS metrics, and management. I also provide commentary on Silicon Valley, venture capital, and the business of software.
</div></div>
		</li>			</ul>
		</div><!-- #primary .widget-area -->

		
		<script type='text/javascript'>
								var _gaq = _gaq || [];
								_gaq.push(['_setAccount', 'UA-122469355-1']);
_gaq.push(['_trackPageview']);

								(function() {
									var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
									ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
									var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
								})();
							</script>
	</div><!-- #content-box -->

	<div id="footer" role="contentinfo">
		
<div id="footer-widget-area" role="complementary">

	<div id="first" class="widget-area">
		<ul class="xoxo">
			<li id="text-2" class="widget-container widget_text">			<div class="textwidget"><a rel="license" href="http://creativecommons.org/licenses/by-nc/4.0/"><img alt="Creative Commons License" style="border-width:0;" src="https://i.creativecommons.org/l/by-nc/4.0/80x15.png" /></a><br /><span>Kellblog</span> by <span>Dave Kellogg</span> is licensed under a <a rel="license" href="http://creativecommons.org/licenses/by-nc/4.0/">Creative Commons Attribution-NonCommercial 4.0 International License</a>. </div>
		</li>		</ul>
	</div><!-- #first .widget-area -->




</div><!-- #footer-widget-area -->
		<div id="colophon">
			<span class="generator-link"><a href="https://wordpress.com/?ref=footer_blog" rel="nofollow">Blog at WordPress.com.</a></span>
					</div><!-- #colophon -->
	</div><!-- #footer -->

</div><!-- #container -->

<!--  -->
	<div style="display:none">
	</div>
<script type='text/javascript'>
/* <![CDATA[ */
var HighlanderComments = {"loggingInText":"Logging In\u2026","submittingText":"Posting Comment\u2026","postCommentText":"Post Comment","connectingToText":"Connecting to %s","commentingAsText":"%1$s: You are commenting using your %2$s account.","logoutText":"Log Out","loginText":"Log In","connectURL":"https:\/\/davidkellogg.wordpress.com\/public.api\/connect\/?action=request&domain=kellblog.com","logoutURL":"https:\/\/davidkellogg.wordpress.com\/wp-login.php?action=logout&_wpnonce=5e5455584a","homeURL":"https:\/\/kellblog.com\/","postID":"14189","gravDefault":"mystery","enterACommentError":"Please enter a comment","enterEmailError":"Please enter your email address here","invalidEmailError":"Invalid email address","enterAuthorError":"Please enter your name here","gravatarFromEmail":"This picture will show whenever you leave a comment. Click to customize it.","logInToExternalAccount":"Log in to use details from one of these accounts.","change":"Change","changeAccount":"Change Account","comment_registration":"","userIsLoggedIn":"","isJetpack":"","text_direction":"ltr"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s2.wp.com/_static/??/wp-content/js/jquery/jquery.autoresize.js,/wp-content/mu-plugins/highlander-comments/script.js?m=1551752381j'></script>

	<div id="carousel-reblog-box">
		<form action="#" name="carousel-reblog">
			<textarea id="carousel-reblog-content" name="carousel-reblog-content" placeholder="Add your thoughts here... (optional)"></textarea>
			<label for="carousel-reblog-to-blog-id" id="carousel-reblog-lblogid">Post to</label>
			<select name="carousel-reblog-to-blog-id" id="carousel-reblog-to-blog-id">
						</select>

			<div class="submit">
				<span class="canceltext"><a href="#" class="cancel">Cancel</a></span>
				<input type="submit" name="carousel-reblog-submit" class="button" id="carousel-reblog-submit" value="Reblog Post" />
				<input type="hidden" id="carousel-reblog-blog-id" value="11070789" />
				<input type="hidden" id="carousel-reblog-blog-url" value="https://kellblog.com" />
				<input type="hidden" id="carousel-reblog-blog-title" value="Kellblog" />
				<input type="hidden" id="carousel-reblog-post-url" value="" />
				<input type="hidden" id="carousel-reblog-post-title" value="" />
			</div>

			<input type="hidden" id="_wpnonce" name="_wpnonce" value="f32ab91f4c" /><input type="hidden" name="_wp_http_referer" value="/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" />		</form>

		<div class="arrow"></div>
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/kellblog.com\/2019\/09\/13\/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards\/":14189};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/2019/09/13/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<div
				class="g-recaptcha"
				data-sitekey="6LcmyE0UAAAAALID28yVNg7pFCodGaArJzHitez_"
				data-theme="light"
				data-type="image"
				data-tabindex="0"></div>
			<script type="text/javascript" src="https://www.google.com/recaptcha/api.js?hl=en" async></script>
			
			<img style="float: right; display: none" class="loading" src="https://s2.wp.com/wp-content/mu-plugins/post-flair/sharing/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='all-css-0-3' href='https://s0.wp.com/wp-content/mu-plugins/carousel/jetpack-carousel.css?m=1563361695h&cssminify=yes' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var actionbardata = {"siteID":"11070789","siteName":"Kellblog","siteURL":"https:\/\/kellblog.com","icon":"<img alt='' src='https:\/\/davidkellogg.files.wordpress.com\/2018\/08\/cropped-dk-headshot-bio-untouched-keffer-1-slate.png?w=50' class='avatar avatar-50' height='50' width='50' \/>","canManageOptions":"","canCustomizeSite":"","isFollowing":"","themeSlug":"pub\/coraline","signupURL":"https:\/\/wordpress.com\/start\/","loginURL":"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fkellblog.com%2F2019%2F09%2F13%2Fkellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards%2F&signup_flow=account&domain=kellblog.com","themeURL":"","xhrURL":"https:\/\/kellblog.com\/wp-admin\/admin-ajax.php","nonce":"03fae4e81f","isSingular":"1","isFolded":"","isLoggedIn":"","isMobile":"","subscribeNonce":"<input type=\"hidden\" id=\"_wpnonce\" name=\"_wpnonce\" value=\"5c4b4bafb3\" \/>","referer":"https:\/\/kellblog.com\/2019\/09\/13\/kellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards\/","canFollow":"1","feedID":"458090","statusMessage":"","customizeLink":"https:\/\/davidkellogg.wordpress.com\/wp-admin\/customize.php?url=https%3A%2F%2Fdavidkellogg.wordpress.com%2F2019%2F09%2F13%2Fkellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards%2F","postID":"14189","shortlink":"https:\/\/wp.me\/pKs17-3GR","canEditPost":"","editLink":"https:\/\/wordpress.com\/post\/kellblog.com\/14189","statsLink":"https:\/\/wordpress.com\/stats\/post\/14189\/kellblog.com","i18n":{"view":"View site","follow":"Follow","following":"Following","edit":"Edit","login":"Log in","signup":"Sign up","customize":"Customize","report":"Report this content","themeInfo":"Get theme: Coraline","shortlink":"Copy shortlink","copied":"Copied","followedText":"New posts from this site will now appear in your <a href=\"https:\/\/wordpress.com\/\">Reader<\/a>","foldBar":"Collapse this bar","unfoldBar":"Expand this bar","editSubs":"Manage subscriptions","viewReader":"View site in Reader","viewReadPost":"View post in Reader","subscribe":"Sign me up","enterEmail":"Enter your email address","followers":"Join 12,701 other followers","alreadyUser":"Already have a WordPress.com account? <a href=\"https:\/\/wordpress.com\/log-in?redirect_to=https%3A%2F%2Fkellblog.com%2F2019%2F09%2F13%2Fkellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards%2F&signup_flow=account&domain=kellblog.com\">Log in now.<\/a>","stats":"Stats"}};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/kellblog.com\/wp-admin\/admin-ajax.php","nonce":"5e7f877040","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/davidkellogg.wordpress.com\/wp-login.php?redirect_to=https%3A%2F%2Fkellblog.com%2F2019%2F09%2F13%2Fkellblogs-greatest-hits-2016-2019-per-the-appealie-saas-awards%2F","blog_id":"11070789","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>","reblog":"Reblog","reblogged":"Reblogged","reblog_add_thoughts":"Add your thoughts here... (optional)","reblogging":"Reblogging...","post_reblog":"Post Reblog","stats_query_args":"blog=11070789&v=wpcom&tz=-7&user_id=0&subd=davidkellogg","is_public":"1","reblog_enabled":""};
/* ]]> */
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://s0.wp.com/_static/??-eJyVUMtOAzEM/CGyAdGFXhCfgkLWbZ3Nq7bT0r/HFWzZQxWJk63xzGQy9lyNL1kgiw1sJzihh/o1BH6wq1Nqpsa2x8w24gxsjw0aHFyeItBCxuxjm/SoRr6kpEJDUONlSJg7jgGkOj/bDzWwckYRICOYIGKGjs5N6ms+HdnkWDW6mXICIryGuGH/dBDSLNwTecGSr6Lbdq8Brn+fXuNBq6PL7xjWrDtveUelMcSlI7MAvXwzcgIxz8PjT6W7QqnDr4XF7KJDsnxwhHm/TBW9p7en8WUzjq/b7SZ8Ax7W0Io='></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
</script>
<script type="text/javascript">
// <![CDATA[
(function() {
try{
  if ( window.external &&'msIsSiteMode' in window.external) {
    if (window.external.msIsSiteMode()) {
      var jl = document.createElement('script');
      jl.type='text/javascript';
      jl.async=true;
      jl.src='/wp-content/plugins/ie-sitemode/custom-jumplist.php';
      var s = document.getElementsByTagName('script')[0];
      s.parentNode.insertBefore(jl, s);
    }
  }
}catch(e){}
})();
// ]]>
</script>		<iframe src='https://widgets.wp.com/likes/master.html?ver=20190321#ver=20190321' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
		<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
<script src="//stats.wp.com/w.js?60" type="text/javascript" async defer></script>
<script type="text/javascript">
_tkq = window._tkq || [];
_stq = window._stq || [];
_tkq.push(['storeContext', {'blog_id':'11070789','blog_tz':'-7','user_lang':'en','blog_lang':'en','user_id':'0'}]);
_stq.push(['view', {'blog':'11070789','v':'wpcom','tz':'-7','user_id':'0','post':'14189','subd':'davidkellogg'}]);
_stq.push(['extra', {'crypt':'UE40eW5QN0p8M2Y/RE1TaVhzUzFMbjdWNHpwZGhTayxPSUFCMGNrd29+Smw0TDhnZmRTK0hlRi9QSGh6bi9GXVhBJWIlZlR5U1JMLU8/MkNtblkvY1d6eXFaMjhuQz1aPzNNMy12XUZlK1VEaF9ZMkRhXS9kfnpXU3U3LUtbLSZsakpoUnExOGVDJWhWOExfT3o/RzQ0TGd+N2VbbVRkJWZubSV4Y3VlNUVXandhdnNPZEVoUCxXenBxdn5GM3ksXUgtPWtrK0xdRmxvLmpmMyZub3gzfkhkdC1hNlROckQtXUU4bDl2NltLSW9DS1JLdlhxUj8tellIV3lfWWQzWUptdT0mQl9VWS9pV2cxVmtsNk1LMCVSNyxJT1VNVnFzOC5GamhLSWosPWpbbXl4bDFiQWRuLWxsSmNuUkV3LWZkUVAxWHNILE9ieHxnWmlUdXVaN1lpMmQ2SFg='}]);
_stq.push([ 'clickTrackerInit', '11070789', '14189' ]);
	</script>
<noscript><img src="https://pixel.wp.com/b.gif?v=noscript" style="height:0px;width:0px;overflow:hidden" alt="" /></noscript>
<script>
if ( 'object' === typeof wpcom_mobile_user_agent_info ) {

	wpcom_mobile_user_agent_info.init();
	var mobileStatsQueryString = "";
	
	if( false !== wpcom_mobile_user_agent_info.matchedPlatformName )
		mobileStatsQueryString += "&x_" + 'mobile_platforms' + '=' + wpcom_mobile_user_agent_info.matchedPlatformName;
	
	if( false !== wpcom_mobile_user_agent_info.matchedUserAgentName )
		mobileStatsQueryString += "&x_" + 'mobile_devices' + '=' + wpcom_mobile_user_agent_info.matchedUserAgentName;
	
	if( wpcom_mobile_user_agent_info.isIPad() )
		mobileStatsQueryString += "&x_" + 'ipad_views' + '=' + 'views';

	if( "" != mobileStatsQueryString ) {
		new Image().src = document.location.protocol + '//pixel.wp.com/g.gif?v=wpcom-no-pv' + mobileStatsQueryString + '&baba=' + Math.random();
	}
	
}
</script></body>
</html>
<!--
	generated in 0.125 seconds
	89902 bytes batcached for 300 seconds
-->
